aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-refhw-gen3/recipes-connectivity/wlconf
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-09-07 11:03:24 -0400
committerScott Murray <scott.murray@konsulko.com>2021-09-09 16:44:21 -0400
commita0117f8c0d614a2d15111db312eebfe9378c868e (patch)
tree0bfe62babbd27521671bf72595ff751d5ca20075 /meta-agl-refhw-gen3/recipes-connectivity/wlconf
parente98aa7a71c06400b50a5c5bdd7e3e576485122bd (diff)
Add WLAN card support
This is loosely based on the contents of the tar file provided with the WLAN cards (AGL_Refhw_sample_software_KK_20210225.tar.gz) with updates for BSP v4.7.0 and other fixes. Changes: - Kernel patches and configuration update to enable the TI WL1837 module. As opposed to the original changes from Panasonic or the Kingfisher support, the HCI LL driver is used instead of the older ti-st + btwilink combination, since the the latter are deprecated and are removed in kernel 5.5. - As part of the above the sound configuration in the devicetree has been reworked to support the WL1837 BT audio. This includes dropping the HDMI1 audio configuration from the original Salvator-X devicetree, as it conflicts with the SSI used for the ak4613 in the reference hardware. - Recipes added for wlconf (from meta-ti) and ti-bt-firmware (loosely derived from the meta-rcar-gen3-adas version). The TI-TFL license used by ti-bt-firmware has been added in a top-level "licenses" directory and that added to LICENSE_PATH in layer.conf to satisfy the license packaging QA checking. Bug-AGL: SPEC-4071 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib17fc01331efe0f49a90f7a8b223ec88b33b44f7
Diffstat (limited to 'meta-agl-refhw-gen3/recipes-connectivity/wlconf')
-rw-r--r--meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
new file mode 100644
index 0000000..42a3248
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Configuration utility for TI wireless drivers"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README;beginline=1;endline=21;md5=adc05a1903d3f107f85c90328e3a9438"
+
+# Tag: R8.7_SP3 (8.7.3)
+SRCREV = "5048b59a444ac59ba7171d6e122d5a84581aebf2"
+SRC_URI = "git://git.ti.com/wilink8-wlan/18xx-ti-utils.git"
+
+S = "${WORKDIR}/git/wlconf"
+
+EXTRA_OEMAKE = "CC="${CC}""
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${sbindir}/wlconf/
+ install -d ${D}${sbindir}/wlconf/official_inis
+ install -d ${D}/lib/firmware/ti-connectivity
+
+ install -m 0755 wlconf ${D}${sbindir}/wlconf/
+ install -m 0755 dictionary.txt ${D}${sbindir}/wlconf/
+ install -m 0755 struct.bin ${D}${sbindir}/wlconf/
+ install -m 0755 default.conf ${D}${sbindir}/wlconf/
+ install -m 0755 wl18xx-conf-default.bin ${D}${sbindir}/wlconf/
+ install -m 0755 wl18xx-conf-default.bin ${D}/lib/firmware/ti-connectivity/wl18xx-conf.bin
+ install -m 0755 README ${D}${sbindir}/wlconf/
+ install -m 0755 example.conf ${D}${sbindir}/wlconf/
+ install -m 0755 example.ini ${D}${sbindir}/wlconf/
+ install -m 0755 configure-device.sh ${D}${sbindir}/wlconf/
+ install -m 0755 ${S}/official_inis/* \
+ ${D}${sbindir}/wlconf/official_inis/
+}
+
+FILES_${PN} += " \
+ ${sbindir}/wlconf \
+ ${sbindir}/wlconf/official_inis \
+ /lib/firmware/ti-connectivity/wl18xx-conf.bin \
+"
+
+FILES_${PN}-dbg += "${sbindir}/wlconf/.debug" \ No newline at end of file