aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-refhw-gen3
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-10-26 11:27:50 -0400
committerScott Murray <scott.murray@konsulko.com>2020-10-26 11:27:50 -0400
commit3b14f194c16405486061a94b32878200fe1dc990 (patch)
treee184607fd61fbb6e1002ab011002ccdceef1f8d4 /meta-agl-refhw-gen3
parent4d116b13c859c61c9f03efd728575ab959b96cdc (diff)
arm-trusted-firmware: add EL2 boot patch from meta-agl-bsp
To generate a-t-f binaries equivalent to what is built for the other H3 based boards in the AGL build process, add the KVM enabling patch that is added by meta-agl-bsp. It is still unclear if there is a straightforward path to working the separate a-t-f build for the reference hardware into the AGL h3ulcb build, so this duplication seems like a necessary evil for now. Bug-AGL: SPEC-3658 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-refhw-gen3')
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend4
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/files/0001-Boot-Normal-World-in-EL2.patch28
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
index 951a34f..bf2874f 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -1,3 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://0001-Boot-Normal-World-in-EL2.patch"
+
# It is believed the eMMC configuration below makes the result AGL
# reference hardware specific, mark it as such to try to prevent
# unintended usage on other boards.
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/files/0001-Boot-Normal-World-in-EL2.patch b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/files/0001-Boot-Normal-World-in-EL2.patch
new file mode 100644
index 0000000..6ce9c0f
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/files/0001-Boot-Normal-World-in-EL2.patch
@@ -0,0 +1,28 @@
+From c97f38b09f8b7d9c57a6e6f500c6ba8f7abd9914 Mon Sep 17 00:00:00 2001
+From: Michele Paolino <m.paolino@virtualopensystems.com>
+Date: Fri, 19 May 2017 14:50:55 +0200
+Subject: [PATCH] Boot Normal World in EL2
+
+This patch configures ATF (SPSR register) to boot BL33 in EL2.
+
+Signed-off-by: Michele Paolino <m.paolino@virtualopensystems.com>
+---
+ plat/renesas/rcar/platform.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plat/renesas/rcar/platform.mk b/plat/renesas/rcar/platform.mk
+index ef7bf0f..06bc592 100644
+--- a/plat/renesas/rcar/platform.mk
++++ b/plat/renesas/rcar/platform.mk
+@@ -186,7 +186,7 @@ $(eval $(call add_define,RCAR_DRAM_SPLIT))
+
+ # Process RCAR_BL33_EXECUTION_EL flag
+ ifndef RCAR_BL33_EXECUTION_EL
+-RCAR_BL33_EXECUTION_EL := 0
++RCAR_BL33_EXECUTION_EL := 1
+ endif
+ $(eval $(call add_define,RCAR_BL33_EXECUTION_EL))
+
+--
+2.7.4
+