aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-11-15 16:43:52 -0500
committerScott Murray <scott.murray@konsulko.com>2020-11-15 16:43:52 -0500
commit6295efdc2f60ea16f48962e7ffc4355dfbdfabf8 (patch)
tree0755e03eecb620ca9956843f9cf5b12b20d57feb /recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
parente8fa8563692fcab198ebedf5f1fa2130b76b8507 (diff)
Changes: - Add can-dev-mapping-helper support changes from meta-agl-demo. It is less than ideal to duplicate them, but the timing of the planned layer reorganization and slimming down of meta-agl makes this seem less hassle. Once the shift to the new layout is done, things can be rationalized as necessary. - Also add the simple_can_simulator.py script, since without any physical CAN connection something is needed to drive testing. Bug-AGL: SPEC-3689 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I655409806026024c804942415ac476e59b916c28
Diffstat (limited to 'recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb')
-rw-r--r--recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
new file mode 100644
index 0000000..37793fd
--- /dev/null
+++ b/recipes-apis/agl-service-can-low-level/can-dev-mapping-helper_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Systemd unit for agl-service-can-low-level CAN device helper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://can-dev-mapping-helper.service \
+ file://can-dev-mapping-helper.sh \
+"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS_${PN} += "bash"