aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-04-22 20:48:47 -0400
committerScott Murray <scott.murray@konsulko.com>2019-04-23 10:58:40 -0400
commite64cdaccca7309e2d3c5da798e01fbea227bd465 (patch)
tree60025a0074482b69d8982af4c1dbd8eec4d46554 /recipes-demo
Define telematics demo platform. This layer is similar to meta-agl-demo and meta-agl-cluster-demo, except it defines a small platform for the telematics demo, based on the agl-profile-telematics profile. There is a "agl-telematics-demo" feature defined to enable building the platform. The defined agl-telematics-demo-platform image contains a minimal amount of services to host a simple demo application that reads CAN events and logs them via the MQTT protocol. At the moment, only the raspberrypi3 version has been built and tested, but there is nothing platform specific in the agl-telematics-demo-recorder application that would prevent use on another platform. Change-Id: I0ed94eefeff703afdcec81884bf16c10c63de28f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/telematics-recorder/telematics-recorder_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo/telematics-recorder/telematics-recorder_git.bb b/recipes-demo/telematics-recorder/telematics-recorder_git.bb
new file mode 100644
index 0000000..148c8b3
--- /dev/null
+++ b/recipes-demo/telematics-recorder/telematics-recorder_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Telematics Recorder AGL Demonstration"
+DESCRIPTION = "AGL Application for demonstrating telematics recorder functionality"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-telematics-demo-recorder"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-telematics-demo-recorder;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS = "glib-2.0 mosquitto"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += " \
+ agl-service-can-low-level \
+ agl-service-gps \
+ agl-service-network \
+ libmosquitto1 \
+"