summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2021-01-21 18:17:51 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-26 11:02:24 +0000
commit1c8b38139fc13ff194297ff136cc04922a52caf1 (patch)
treed3f2a0fafb426c42e2ac04145884be1530f50c03
parent6aeddccaa595610ad4c8c9899734779c11bd7da0 (diff)
raspberrypi: Upgrade to u-boot v2020.10
The newer u-boot version supports the network interface on the rpi4, allowing us to do things like DHCP boot. Also switch to the preferred "rpi_arm64" u-boot config. Bug-AGL: SPEC-2983 Signed-off-by: Paul Barker <pbarker@konsulko.com> Change-Id: I0dff4779f98c7ce6394efd9feb58b7f2a8933296 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25937 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi4.inc4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb2
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb2
4 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
index ae302aae1..c44d44f8f 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
@@ -26,3 +26,7 @@ IMAGE_INSTALL_append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools
# Add xen-raspberry binary to boot files
IMAGE_BOOT_FILES_append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
+
+PREFERRED_VERSION_u-boot = "2020.10"
+PREFERRED_VERSION_u-boot-tools = "2020.10"
+UBOOT_MACHINE_rpi = "rpi_arm64_config"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc
new file mode 100644
index 000000000..27f46096a
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc
@@ -0,0 +1,3 @@
+SRC_URI = "git://git.denx.de/u-boot.git"
+SRCREV = "050acee119b3757fee3bd128f55d720fdd9bb890"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb
new file mode 100644
index 000000000..2d9d76955
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+require u-boot-2020.10.inc
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb
new file mode 100644
index 000000000..0d967575b
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot_2020.01.bb
+require u-boot-2020.10.inc