summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2017-10-10 19:25:59 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-11 14:24:55 +0000
commita5f69d3d31e7d75351f0e2abfc36d35ba39ce304 (patch)
treed578e3847c1cd9d6aeabdd0fd5468cbed2670a3d
parent8df0659bec1fa361164f6c975a385579f89aa902 (diff)
Fix kernel-devsrc package failing during installdab_4.0.2dab/4.0.24.0.2
This issue is due to the upstream script hardcodes /bin/awk whereas we ship /usr/bin/awk. The installation check will break in this case. Fix it by changing the path in the script. References: - https://lists.yoctoproject.org/pipermail/meta-intel/2017-January/004519.html - https://patchwork.openembedded.org/patch/136699/ - http://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/commit/?h=yocto-4.9&id=d0e0a36eec57f5dfa02045776c69092c145f5000 Bug-AGL: SPEC-933 Change-Id: I228351663b764378960051463086e32c81b9b3d2 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11209 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Romain Forlot <romain.forlot@iot.bzh> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Thomas Rini <trini@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/kernel-devsrc.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/kernel-devsrc.bbappend b/meta-agl-bsp/recipes-kernel/linux/kernel-devsrc.bbappend
new file mode 100644
index 000000000..406aad1eb
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/kernel-devsrc.bbappend
@@ -0,0 +1,7 @@
+
+do_install_append() {
+ # enforce all scripts to use /usr/bin/awk . This fixes the rpm dependency failure on install of kernel-devsrc
+ cd ${D} || true
+ ( for i in `grep -srI "\!/bin/awk" | cut -d":" -f1 ` ; do sed -i -e "s#\!/bin/awk#\!/usr/bin/env awk#g" $i ; done ) || true
+}
+