summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@daimler.com>2019-11-01 12:07:44 +0100
committerLeon Anavi <leon.anavi@konsulko.com>2019-11-06 13:44:02 +0200
commitf356dcc8b1971ff0d024f02558a7fbb5d79d9b4b (patch)
treea844e65890264d6b48204a12a3f8eb449f185527
parent02e99515e7af6df1787eaf05d0969672560ce658 (diff)
rpi-config: Set max_framebuffers to 2 to support dual display
Change-Id: Id9ca08ede2aedbc122a04d97ca4bb5bd8478b717 Signed-off-by: Changhyeok Bae <changhyeok.bae@daimler.com>
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 5c74cae7b..5eecff6f1 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -35,6 +35,11 @@ do_deploy_append() {
echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}
+do_deploy_append_raspberrypi4() {
+ echo -e "\n[pi4]" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "max_framebuffers=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}
+
do_deploy_append_sota() {
echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}