aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2015-12-08 03:35:43 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2015-12-08 20:08:52 +0000
commit3f47347984890cc447161229552fe172ec73d27e (patch)
tree5db952cb42ed7f9739fb66f528caf98f9f65a63b
parent2c29cda4ae86108ca711b0a36df555fd0d1f7bb9 (diff)
AMB (automotive-message-broker): enable gpsnmea plugin
In this version of AMB, GPS plugin is named "gpsnmea" and does not really depend on gpsd, so fix the build option and remove the dependency. If gpsnmea is enabled (default), we should ship a matching configuration file so that it gets loaded automatically. Consider an USB GPS device ; at worst, if no device is present, harmless NULL values will be returned by AMB. Change-Id: I60fc960bff04b334a2556b9ec92a4089398d453e Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps7
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb6
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc1
3 files changed, 13 insertions, 1 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps
new file mode 100644
index 000000000..be8e52e62
--- /dev/null
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/gps
@@ -0,0 +1,7 @@
+{
+ "name" : "gpsnmea",
+ "path" : "/usr/lib//automotive-message-broker/gpsnmea.so",
+ "device" : "/dev/ttyUSB0",
+ "baudrate" : "4800",
+ "enabled" : true
+}
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
index 4873f12a0..2894b2ce1 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
@@ -16,7 +16,7 @@ RDEPENDS_${PN} = "python-misc python-json"
PACKAGECONFIG ??= " use_gps \
${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','use_qt5','', d)} \
"
-PACKAGECONFIG[use_gps] = "-Dgpsd_plugins=On,,gpsd"
+PACKAGECONFIG[use_gps] = "-Dgpsnmea_plugin=On"
PACKAGECONFIG[use_qt5] = "-Dqtmainloop=On -Dqt_bindings=On,,qtbase qtdeclarative"
SYSTEMD_PACKAGES = "${PN}"
@@ -33,6 +33,10 @@ do_install_append() {
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/ambd.service ${D}${systemd_unitdir}/system
+
+ if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
+ install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
+ fi
}
FILES_${PN} += " ${systemd_unitdir}/ambd.service \
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
index 9cef0d5ae..377e9ebc1 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
@@ -21,6 +21,7 @@ SRC_URI += " \
file://0009-Add-Pressure-property-to-BrakeOperation.patch \
file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch \
file://ambd.service \
+ file://gps \
"
S = "${WORKDIR}/git"