aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2015-11-02 12:05:27 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-11-09 16:50:25 +0000
commit9de2f871c04c5c49dcb39c38e2c87d84a6e2741e (patch)
tree59d4f52cbd4cc1c7fd2d2847d4acc2763c1c26cf
parent6e22b075ed57a0fb3ed5af68e029c291adc309d5 (diff)
Security: Adding the library xmlsec
XmlSec is a library used for signing, validating, and crypting XML files according to XMLDSIG, the recommendation of the W3C. See http://www.w3.org/TR/xmldsig-core1 The library is integrated with use of openSSL only and without XSLT library integration. Change-Id: I685e3b476d936bcedb52dd88da9f4286182e0c58 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb b/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb
new file mode 100644
index 000000000..7faf7bfd4
--- /dev/null
+++ b/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb
@@ -0,0 +1,40 @@
+inherit autotools pkgconfig
+
+SUMMARY = "Library providing support for "XML Signature" and "XML Encryption" standards"
+DESCRIPTION = "XML Security Library is a C library based on LibXML2 and OpenSSL. \
+The library was created with a goal to support major XML security \
+standards "XML Digital Signature" and "XML Encryption". \
+"
+
+HOMEPAGE = "https://www.aleksey.com/xmlsec"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://Copyright;md5=32e47e213c77c55d2c666351d7ce16b5"
+
+SRC_URI = "git://git.gnome.org/xmlsec;branch=master;protocol=git"
+SRCREV = "84c8281cf927b1cdcc38f343f61c3aa448a5a10f"
+
+SECTION = "base"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "openssl libxml2"
+
+# choice is made to use openssl only and to not use xslt
+# nss would be a valuable choice
+EXTRA_OECONF = "\
+ --disable-crypto-dl \
+ --disable-apps-crypto-dl \
+ --enable-shared \
+ --disable-static \
+ --without-gnutls \
+ --without-gcrypt \
+ --without-nss \
+ --without-libxslt \
+"
+
+do_install_append() {
+ # discarding this optional file is good for AGL
+ rm ${D}${libdir}/xmlsec1Conf.sh
+}
+
+