aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-05-10 12:03:57 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:38:09 +0000
commit031fb0847465c761538fb49a46897d81c6316c77 (patch)
tree0e711878bf195cc383ed03fa26a8fa4db1506166
parent8176e8bfdeb01950841bc300dd82f4da27a65c39 (diff)
tests: Add new recipe for ipv6connect
Change-Id: Ib1f68f6680452d194e4cb3ac642774fa58acf3a9 Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb b/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb
new file mode 100644
index 000000000..2fc6933ea
--- /dev/null
+++ b/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb
@@ -0,0 +1,22 @@
+SUMMARY = "ipv6connect test"
+HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/0.12.369.B/client/tests/ipv6connect"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${S}/${PN}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRCREV = "b355b7e1f43a19938895964f314484ffd8a39542"
+
+inherit autotools
+
+B = "${WORKDIR}/git/ipv6connect"
+S = "${WORKDIR}/git"
+
+# configure script is not delivered, only a makefile.
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${B}/ipv6connect ${D}${bindir}
+}