aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-05-04 12:35:03 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-06 21:46:42 +0000
commit084ab213bd37fb22b4f2bd2e23859b719778c4cc (patch)
tree415eae01352aee9f1fbcc57ecd254543233fbbdc
parent6f6eaaf6ab72f73a7bb9e568eb4f13b0f05fd95a (diff)
rvi-sota-client_git: add RVI SOTA client
Build and deploy sota_client and a systemd service. The application is written in the Rust programming language and depends on Cargo therefore the recipe requires on meta-rust. It is using crate dbus-rs version 0.1.2 with fixed casts of c_char raw pointers for ARM. Bug-AGL: SPEC-176 Change-Id: Ic8f24ae3dd2e62297e303be23a40759b0b919b86 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-agl/recipes-sota/rvi-sota-client/files/dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch146
-rw-r--r--meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client/rvi-sota-client.service9
-rw-r--r--meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb40
-rw-r--r--templates/dra7xx-evm/conf/bblayers.conf.sample1
-rw-r--r--templates/dragonboard-410c/conf/bblayers.conf.sample1
-rw-r--r--templates/intel-corei7-64/conf/bblayers.conf.sample1
-rw-r--r--templates/qemux86-64/conf/bblayers.conf.sample1
-rw-r--r--templates/qemux86/conf/bblayers.conf.sample1
-rw-r--r--templates/raspberrypi2/conf/bblayers.conf.sample1
-rw-r--r--templates/raspberrypi3/conf/bblayers.conf.sample1
-rw-r--r--templates/wandboard/conf/bblayers.conf.sample1
11 files changed, 203 insertions, 0 deletions
diff --git a/meta-agl/recipes-sota/rvi-sota-client/files/dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch b/meta-agl/recipes-sota/rvi-sota-client/files/dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch
new file mode 100644
index 000000000..2d3dbedca
--- /dev/null
+++ b/meta-agl/recipes-sota/rvi-sota-client/files/dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch
@@ -0,0 +1,146 @@
+From 768202d3223813e71848758ecafcfeab276d9101 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Sat, 12 Mar 2016 17:52:02 +0200
+Subject: [PATCH] Cast correctly c_char raw pointers for ARM
+
+Fix the build of crate dbus-rs (version 0.1.2) for ARM
+with correct casts of c_char raw pointers.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ src/lib.rs | 18 +++++++++---------
+ src/message.rs | 10 +++++-----
+ 2 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/src/lib.rs b/src/lib.rs
+index aac9c0f..8134dc4 100644
+--- a/src/lib.rs
++++ b/src/lib.rs
+@@ -60,7 +60,7 @@ unsafe impl Send for Error {}
+
+ fn c_str_to_slice(c: & *const libc::c_char) -> Option<&str> {
+ if *c == ptr::null() { None }
+- else { std::str::from_utf8( unsafe { CStr::from_ptr(*c).to_bytes() }).ok() }
++ else { std::str::from_utf8( unsafe { CStr::from_ptr(*c as *const _).to_bytes() }).ok() }
+ }
+
+ fn to_c_str(n: &str) -> CString { CString::new(n.as_bytes()).unwrap() }
+@@ -72,7 +72,7 @@ impl Error {
+ let m = to_c_str(&message.replace("%","%%"));
+ let mut e = Error::empty();
+
+- unsafe { ffi::dbus_set_error(e.get_mut(), n.as_ptr(), m.as_ptr()) };
++ unsafe { ffi::dbus_set_error(e.get_mut(), n.as_ptr() as *const _, m.as_ptr() as *const _) };
+ e
+ }
+
+@@ -272,21 +272,21 @@ impl Connection {
+ };
+ let r = unsafe {
+ let user_data: *mut libc::c_void = std::mem::transmute(&*self.i);
+- ffi::dbus_connection_try_register_object_path(self.conn(), p.as_ptr(), &vtable, user_data, e.get_mut())
++ ffi::dbus_connection_try_register_object_path(self.conn(), p.as_ptr() as *const _, &vtable, user_data, e.get_mut())
+ };
+ if r == 0 { Err(e) } else { Ok(()) }
+ }
+
+ pub fn unregister_object_path(&self, path: &str) {
+ let p = to_c_str(path);
+- let r = unsafe { ffi::dbus_connection_unregister_object_path(self.conn(), p.as_ptr()) };
++ let r = unsafe { ffi::dbus_connection_unregister_object_path(self.conn(), p.as_ptr() as *const _) };
+ if r == 0 { panic!("Out of memory"); }
+ }
+
+ pub fn list_registered_object_paths(&self, path: &str) -> Vec<String> {
+ let p = to_c_str(path);
+ let mut clist: *mut *mut libc::c_char = ptr::null_mut();
+- let r = unsafe { ffi::dbus_connection_list_registered(self.conn(), p.as_ptr(), &mut clist) };
++ let r = unsafe { ffi::dbus_connection_list_registered(self.conn(), p.as_ptr() as *const _, &mut clist) };
+ if r == 0 { panic!("Out of memory"); }
+ let mut v = Vec::new();
+ let mut i = 0;
+@@ -306,28 +306,28 @@ impl Connection {
+ pub fn register_name(&self, name: &str, flags: u32) -> Result<RequestNameReply, Error> {
+ let mut e = Error::empty();
+ let n = to_c_str(name);
+- let r = unsafe { ffi::dbus_bus_request_name(self.conn(), n.as_ptr(), flags, e.get_mut()) };
++ let r = unsafe { ffi::dbus_bus_request_name(self.conn(), n.as_ptr() as *const _, flags, e.get_mut()) };
+ if r == -1 { Err(e) } else { Ok(unsafe { std::mem::transmute(r) }) }
+ }
+
+ pub fn release_name(&self, name: &str) -> Result<ReleaseNameReply, Error> {
+ let mut e = Error::empty();
+ let n = to_c_str(name);
+- let r = unsafe { ffi::dbus_bus_release_name(self.conn(), n.as_ptr(), e.get_mut()) };
++ let r = unsafe { ffi::dbus_bus_release_name(self.conn(), n.as_ptr() as *const _, e.get_mut()) };
+ if r == -1 { Err(e) } else { Ok(unsafe { std::mem::transmute(r) }) }
+ }
+
+ pub fn add_match(&self, rule: &str) -> Result<(), Error> {
+ let mut e = Error::empty();
+ let n = to_c_str(rule);
+- unsafe { ffi::dbus_bus_add_match(self.conn(), n.as_ptr(), e.get_mut()) };
++ unsafe { ffi::dbus_bus_add_match(self.conn(), n.as_ptr() as *const _, e.get_mut()) };
+ if e.name().is_some() { Err(e) } else { Ok(()) }
+ }
+
+ pub fn remove_match(&self, rule: &str) -> Result<(), Error> {
+ let mut e = Error::empty();
+ let n = to_c_str(rule);
+- unsafe { ffi::dbus_bus_remove_match(self.conn(), n.as_ptr(), e.get_mut()) };
++ unsafe { ffi::dbus_bus_remove_match(self.conn(), n.as_ptr() as *const _, e.get_mut()) };
+ if e.name().is_some() { Err(e) } else { Ok(()) }
+ }
+
+diff --git a/src/message.rs b/src/message.rs
+index 23871f8..e3dd021 100644
+--- a/src/message.rs
++++ b/src/message.rs
+@@ -126,7 +126,7 @@ fn iter_append_array(i: &mut ffi::DBusMessageIter, a: &[MessageItem], t: TypeSig
+ let mut subiter = new_dbus_message_iter();
+ let atype = to_c_str(&t);
+
+- assert!(unsafe { ffi::dbus_message_iter_open_container(i, ffi::DBUS_TYPE_ARRAY, atype.as_ptr(), &mut subiter) } != 0);
++ assert!(unsafe { ffi::dbus_message_iter_open_container(i, ffi::DBUS_TYPE_ARRAY, atype.as_ptr() as *const _, &mut subiter) } != 0);
+ for item in a.iter() {
+ // assert!(item.type_sig() == t);
+ item.iter_append(&mut subiter);
+@@ -148,7 +148,7 @@ fn iter_append_struct(i: &mut ffi::DBusMessageIter, a: &[MessageItem]) {
+ fn iter_append_variant(i: &mut ffi::DBusMessageIter, a: &MessageItem) {
+ let mut subiter = new_dbus_message_iter();
+ let atype = to_c_str(&format!("{}", a.array_type() as u8 as char));
+- assert!(unsafe { ffi::dbus_message_iter_open_container(i, ffi::DBUS_TYPE_VARIANT, atype.as_ptr(), &mut subiter) } != 0);
++ assert!(unsafe { ffi::dbus_message_iter_open_container(i, ffi::DBUS_TYPE_VARIANT, atype.as_ptr() as *const _, &mut subiter) } != 0);
+ a.iter_append(&mut subiter);
+ assert!(unsafe { ffi::dbus_message_iter_close_container(i, &mut subiter) } != 0);
+ }
+@@ -481,7 +481,7 @@ impl Message {
+ init_dbus();
+ let (d, p, i, m) = (to_c_str(destination), to_c_str(path), to_c_str(iface), to_c_str(method));
+ let ptr = unsafe {
+- ffi::dbus_message_new_method_call(d.as_ptr(), p.as_ptr(), i.as_ptr(), m.as_ptr())
++ ffi::dbus_message_new_method_call(d.as_ptr() as *const _, p.as_ptr() as *const _, i.as_ptr() as *const _, m.as_ptr() as *const _)
+ };
+ if ptr == ptr::null_mut() { None } else { Some(Message { msg: ptr} ) }
+ }
+@@ -490,7 +490,7 @@ impl Message {
+ init_dbus();
+ let (p, i, m) = (to_c_str(path), to_c_str(iface), to_c_str(method));
+ let ptr = unsafe {
+- ffi::dbus_message_new_signal(p.as_ptr(), i.as_ptr(), m.as_ptr())
++ ffi::dbus_message_new_signal(p.as_ptr() as *const _, i.as_ptr() as *const _, m.as_ptr() as *const _)
+ };
+ if ptr == ptr::null_mut() { None } else { Some(Message { msg: ptr} ) }
+ }
+@@ -502,7 +502,7 @@ impl Message {
+
+ pub fn new_error(m: &Message, error_name: &str, error_message: &str) -> Option<Message> {
+ let (en, em) = (to_c_str(error_name), to_c_str(error_message));
+- let ptr = unsafe { ffi::dbus_message_new_error(m.msg, en.as_ptr(), em.as_ptr()) };
++ let ptr = unsafe { ffi::dbus_message_new_error(m.msg, en.as_ptr() as *const _, em.as_ptr() as *const _) };
+ if ptr == ptr::null_mut() { None } else { Some(Message { msg: ptr} ) }
+ }
+
+--
+2.1.4
+
diff --git a/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client/rvi-sota-client.service b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client/rvi-sota-client.service
new file mode 100644
index 000000000..d99f9d606
--- /dev/null
+++ b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client/rvi-sota-client.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=RVI SOTA Client
+
+[Service]
+User=root
+ExecStart=/usr/bin/run.sh
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
new file mode 100644
index 000000000..38c645ae4
--- /dev/null
+++ b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "SOTA Reference Implementation project - Client"
+HOMEPAGE = "https://github.com/advancedtelematic/rvi_sota_client"
+LICENSE = "MPL-2.0"
+
+inherit cargo systemd
+
+SRC_URI = "git://github.com/advancedtelematic/rvi_sota_client.git;protocol=https \
+ file://rvi-sota-client.service \
+ "
+SRCREV="825be11b03f89c52e5441b3d26e1cbf63fd313dd"
+LIC_FILES_CHKSUM="file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "dbus"
+RDEPENDS_${PN} += "dbus-lib libcrypto libssl bash"
+
+SYSTEMD_SERVICE_${PN} = "rvi-sota-client.service"
+
+do_install_append() {
+ install -m 0755 -p -D ${S}/client.toml ${D}/var/sota/client.toml
+ install -m 0755 -p -D ${S}/docker/run.sh ${D}${bindir}/run.sh
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -p -D ${WORKDIR}/rvi-sota-client.service ${D}${systemd_unitdir}/system/rvi-sota-client.service
+ fi
+}
+
+## dbus-rs
+SRC_URI += "\
+ git://github.com/diwic/dbus-rs.git;protocol=https;name=dbus-rs;destsuffix=dbus-rs \
+ file://dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch;patchdir=../dbus-rs \
+"
+
+# 0.1.2
+SRCREV_dbus-rs = "c2c4c98adcf9949992ac5b0050bf17afe10868c9"
+
+SRCREV_FORMAT .= "_dbus-rs"
+EXTRA_OECARGO_PATHS += "${WORKDIR}/dbus-rs"
diff --git a/templates/dra7xx-evm/conf/bblayers.conf.sample b/templates/dra7xx-evm/conf/bblayers.conf.sample
index a0ba47efa..f7d577fec 100644
--- a/templates/dra7xx-evm/conf/bblayers.conf.sample
+++ b/templates/dra7xx-evm/conf/bblayers.conf.sample
@@ -19,6 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-ti \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/dragonboard-410c/conf/bblayers.conf.sample b/templates/dragonboard-410c/conf/bblayers.conf.sample
index 8e1442ec5..8198c3623 100644
--- a/templates/dragonboard-410c/conf/bblayers.conf.sample
+++ b/templates/dragonboard-410c/conf/bblayers.conf.sample
@@ -19,6 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-qcom \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/intel-corei7-64/conf/bblayers.conf.sample b/templates/intel-corei7-64/conf/bblayers.conf.sample
index 9b0e38388..b7c0b9cdc 100644
--- a/templates/intel-corei7-64/conf/bblayers.conf.sample
+++ b/templates/intel-corei7-64/conf/bblayers.conf.sample
@@ -19,6 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-intel \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/qemux86-64/conf/bblayers.conf.sample b/templates/qemux86-64/conf/bblayers.conf.sample
index b3047f78b..8a92fefa2 100644
--- a/templates/qemux86-64/conf/bblayers.conf.sample
+++ b/templates/qemux86-64/conf/bblayers.conf.sample
@@ -18,6 +18,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-efl \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
+ ##OEROOT##/../meta-openembedded/meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/qemux86/conf/bblayers.conf.sample b/templates/qemux86/conf/bblayers.conf.sample
index b3047f78b..8a92fefa2 100644
--- a/templates/qemux86/conf/bblayers.conf.sample
+++ b/templates/qemux86/conf/bblayers.conf.sample
@@ -18,6 +18,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-efl \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
+ ##OEROOT##/../meta-openembedded/meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/raspberrypi2/conf/bblayers.conf.sample b/templates/raspberrypi2/conf/bblayers.conf.sample
index 108d927c1..98eb76ecc 100644
--- a/templates/raspberrypi2/conf/bblayers.conf.sample
+++ b/templates/raspberrypi2/conf/bblayers.conf.sample
@@ -19,6 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-raspberrypi \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/raspberrypi3/conf/bblayers.conf.sample b/templates/raspberrypi3/conf/bblayers.conf.sample
index 108d927c1..98eb76ecc 100644
--- a/templates/raspberrypi3/conf/bblayers.conf.sample
+++ b/templates/raspberrypi3/conf/bblayers.conf.sample
@@ -19,6 +19,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-networking \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-raspberrypi \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \
diff --git a/templates/wandboard/conf/bblayers.conf.sample b/templates/wandboard/conf/bblayers.conf.sample
index 1714e1f12..ec5cbca92 100644
--- a/templates/wandboard/conf/bblayers.conf.sample
+++ b/templates/wandboard/conf/bblayers.conf.sample
@@ -20,6 +20,7 @@ BBLAYERS ?= " \
##OEROOT##/../meta-openembedded/meta-python \
##OEROOT##/../meta-fsl-arm \
##OEROOT##/../meta-fsl-arm-extra \
+ ##OEROOT##/../meta-rust \
"
BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta \