aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-07-19 11:07:23 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-07-19 13:44:30 +0000
commit268b19f7d809649a15f3596f317582fb4ff23064 (patch)
tree098591fa1e892838f15eaaae93d4b5a6d202f904
parente1825a156c7384b21ef2a93436016661b780daaf (diff)
vmdk images need harddisk drivers built-in
This patch adds the disk drivers as to the kernel to be able to boot the vmdk images w/o initrd (only qemux86 and qemux86_64). v2: use _append as it is a parsed expression Change-Id: I3ebfe09079754fa29a008d14e1d0bcd3c7e98f84 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> (cherry picked from commit baa986abe444dbbfd59b63f6111a058b80891474)
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg7
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend4
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg
new file mode 100644
index 000000000..360a5a420
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg
@@ -0,0 +1,7 @@
+# enable harddrive driver for vmware/virtualbox
+CONFIG_ATA_PIIX=y
+CONFIG_SATA_AHCI=y
+CONFIG_ATA_SFF=y
+CONFIG_ATA_BMDMA=y
+CONFIG_ATA_GENERIC=y
+CONFIG_ATA_ACPI=y
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 6f1ed9bc3..7f7fdf5ff 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -5,3 +5,7 @@ SRC_URI += "file://fanotify.cfg \
file://uinput.cfg \
file://hid.cfg \
"
+
+# disk drivers for vmdk
+SRC_URI_append_qemux86 = " file://vbox-vmware-sata.cfg "
+SRC_URI_append_qemux86_64 = " file://vbox-vmware-sata.cfg "