aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-14 10:34:12 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:29:39 +0000
commit28ec56de3303f79a1cae1b47ccfd03670fbdf1f6 (patch)
tree4827d053d5929a21917494cf580d66a7bede2ef3
parentacf8cd14ba5b53c774c85d4f7b177d5709be2e59 (diff)
meta-ivi-common: add recipe for 'dung' scripts required by some JTA tests
The following tests use dung-3.4.25-m2 scripts: * Functional.arch_timer * Functional.scifab * Functional.cmt * Functional.sdhi_0 Change-Id: Ibcd4267b6b2025e0e615fcb6af2bbaa3b2011712 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-test/dung/dung_3.4.25-m2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/dung/dung_3.4.25-m2.bb b/meta-ivi-common/recipes-test/dung/dung_3.4.25-m2.bb
new file mode 100644
index 000000000..190e4d7e7
--- /dev/null
+++ b/meta-ivi-common/recipes-test/dung/dung_3.4.25-m2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Kernel test scripts"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRCREV = "e2472c7b1d061aef8bb05a4d7940fd8159c4a329"
+
+inherit allarch
+
+S = "${WORKDIR}/git/${PN}-${PV}"
+
+do_install () {
+ for subdir in arch_timer cmt common scifab sdhi.0; do
+ install -d -m 0755 ${D}/${datadir}/${PN}/$subdir
+ install -m 0755 -t ${D}/${datadir}/${PN}/$subdir ${S}/$subdir/*
+ done
+}
+