aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2016-07-21 23:18:33 +0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-08-03 20:36:48 +0000
commit53edb74c45bd7a9d32756ebece7da07ab02cadee (patch)
tree42ece158551eb3bdb4223851253b60989cdafa9c
parent6984b79c1bbc70526a8bc7b319bc3d8d965ee7ff (diff)
Fix do_install issue for freetype-native
The TOP_DIR is wrong in case native compile. The value of PN=freetype-native. It causes do_install error. This is error log of the issue install: cannot stat '...build/tmp/work/x86_64-linux/freetype-native/2.6-r0/ft2demos-2.6/bin/ftbench': No such file or directory (virtual:native: .../freetype_2.6.bb,do_install) failed with exit code '1' This will change to use BPN instead of PN. BPN=freetype in both native and cross compile. Tested OK with bitbake freetype freetype-native. Change-Id: I5a2b5bcc80755165ba026aedd177d03bc3f0e4a5 Signed-off-by: Phong Tran <tranmanphong@gmail.com> (cherry picked from commit be991aaa39202388b212cbb8de25d50313d8472f)
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
index 835580f1d..94d73aa55 100644
--- a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
+++ b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
@@ -9,7 +9,7 @@ SRC_URI[ft2demos.sha256sum] = "f8f4bc2a2e76e0dbe61838e452c5a7daf1d4bd9dfa4469194
PACKAGES =+ "${PN}-demos"
do_compile_append () {
- oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${PN}-${PV}
+ oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}
}
do_install_append () {