aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-05-09 12:45:39 +0000
committerLeon Anavi <leon.anavi@konsulko.com>2016-05-10 13:39:38 +0000
commitb4dedf13f6545df00893e080e51c782e23ca00b3 (patch)
tree7bfa89e3d36b1bd621e728d280c233c1dfa91361
parenta1e6f20828d629a6e08286fed5e8cfba0862948e (diff)
rvi-sota-client_git: Fix openssl and hyper version
Set specific versions of crates openssl and hyper which are known to be compatible with this version of RVI SOTA client. Bug-AGL: SPEC-176 Change-Id: I38c982963b88507ddc6d40cce1145af54886a0e1 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index 38c645ae4..8d3c78cac 100644
--- a/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -38,3 +38,21 @@ SRCREV_dbus-rs = "c2c4c98adcf9949992ac5b0050bf17afe10868c9"
SRCREV_FORMAT .= "_dbus-rs"
EXTRA_OECARGO_PATHS += "${WORKDIR}/dbus-rs"
+
+## rust-openssl
+SRC_URI += "git://github.com/sfackler/rust-openssl.git;protocol=https;name=rust-openssl;destsuffix=rust-openssl "
+
+# 0.7.10
+SRCREV_rust-openssl = "d6bc3bb16f2673f610e9310041fc030ea9b90187"
+
+SRCREV_FORMAT .= "_rust-openssl"
+EXTRA_OECARGO_PATHS += "${WORKDIR}/rust-openssl"
+
+## hyper
+SRC_URI += "git://github.com/hyperium/hyper.git;protocol=https;name=hyper;destsuffix=hyper "
+
+# 0.9.1
+SRCREV_hyper = "4828437551c7f5ed3f54acb1c1bf1fd50a6a3516"
+
+SRCREV_FORMAT .= "_hyper"
+EXTRA_OECARGO_PATHS += "${WORKDIR}/hyper"