aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-06-08 13:41:49 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-07-15 12:22:42 +0000
commitc2bacc9e034e65cac028b2e4e28cf4f7a4bf4dcc (patch)
tree3ac57992c7ffe5bf5ac7040f798506e041d1b4d2
parent203e07c635fab8b1986f48a40351137b8ec67946 (diff)
Add agl-audio-plugin (PulseAudio Routing plugin)
agl-audio-plugin is a stripped-down version of the former Tizen IVI Audio Routing plugin (also known as "module- murphy-ivi"). This is stripped down is the sense that: - it does not require Murphy anymore; - it does not implement the most complex use cases anymore; - it is able to work standalone by using a JSON configuration file or its own embedded configuration. It still has the basic structure needed to interconnect an external policy engine (such as GENIVI AudioManager). Change-Id: I133916cada5cc928187f2aef6448fdaf7c03c3c6 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb24
-rw-r--r--meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb b/meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
new file mode 100644
index 000000000..8e19b91c1
--- /dev/null
+++ b/meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "AGL Audio Policy Plugin"
+DESCRIPTION = "AGL PulseAudio Routing plugin, forked from the Tizen IVI \
+PulseAudio Routing plugin, also known as module-murphy-ivi. This is a \
+stripped-down version of the former, not needing Murphy anymore and using \
+either a JSON configuration file or its own embedded configuration."
+HOMEPAGE = "http://www.iot.bzh"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "json-c pulseaudio"
+RDEPENDS_${PN} = "pulseaudio-server pulseaudio-module-null-sink pulseaudio-module-loopback"
+
+SRCREV = "2d5b809de9d5b69fb9b1ad9e0f3ee5bd53eb2785"
+SRC_URI = "git://github.com/iotbzh/agl-audio-plugin;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+FULL_OPTIMIZATION = "-O1 -pipe ${DEBUG_FLAGS}"
+
+FILES_${PN} += "${libdir}/pulse-6.0/modules/* ${sysconfdir}/pulse/*"
+FILES_${PN}-dbg += "${libdir}/pulse-6.0/modules/.debug/*"
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
index 87ff66a26..40cd116dd 100644
--- a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
+++ b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
@@ -14,5 +14,6 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
alsa-lib \
alsa-utils \
+ agl-audio-plugin \
gstreamer1.0-meta-base \
"