summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Field <dennisf@radiosound.com>2016-11-09 15:55:05 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-11 13:44:17 +0000
commitdd8aa67bfee8887e1943ad4ef49232ea04025330 (patch)
tree41a258c84e3cc3caffd01b1a891b35ea4f136e86
parent7a832073f35a54fe2db8b7045c944b4af96505e0 (diff)
weston: Set XDG_RUNTIME_DIR for fsl-arm
Without this environment variable, Weston fails to start on Wandboard Bug-AGL: SPEC-318 Change-Id: I42696f45d9a9b78dfeea905d3c5066845056894e Signed-off-by: Dennis Field <dennisf@radiosound.com>
-rw-r--r--meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend14
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh
new file mode 100644
index 000000000..225a034bb
--- /dev/null
+++ b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston/weston.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/$UID
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+fi
diff --git a/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend
new file mode 100644
index 000000000..bdb6e44de
--- /dev/null
+++ b/meta-agl-bsp/meta-fsl-arm/recipes-graphics/weston/weston_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston.sh \
+ "
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/profile.d/weston.sh \
+ "