summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-23 21:25:27 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-24 03:10:29 +0000
commit496925b6a16444c816b3ea24b6de4e53650084e6 (patch)
tree5ab0438bda0bb79664bb4955b2869bcd214077fd
parentecea85c853214fa4c67811f5066f894582e1d7c2 (diff)
weston: Set XDG_RUNTIME_DIR for qcom
Without this environment variable, Weston fails to start on Dragonboard * backport from master commit 0a34b88c4b661a91962dd0c04c3af7e582bafcbd Change-Id: I67ad6ec7cb2ad4cdcf0885e42d0b297d87ec43d3 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini13
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend20
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
new file mode 100644
index 000000000..3daad91dd
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
@@ -0,0 +1,13 @@
+[core]
+backend=drm-backend.so
+shell=ivi-shell.so
+
+[ivi-shell]
+ivi-module=ivi-controller.so,wl-shell-emulator.so
+ivi-input-module=ivi-input-controller.so
+
+[output]
+name=HDMI-A-1
+transform=270
+# Uncomment for 1080p on GeChic 1502i:
+#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
new file mode 100644
index 000000000..225a034bb
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/$UID
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+fi
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..8fff1dfe7
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-qcom.ini \
+ file://weston.sh \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-qcom.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
+ "