summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2016-12-28 07:45:15 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-30 09:46:32 +0000
commit0723eddcb9d683a9b9e0ee03a8455e2ce78cc8fc (patch)
treed15fa04f03096ef10608bc8d774eab28da69bae2
parent0a42053a5cb42806fdedba08fc0b5a3ec02f687e (diff)
linux-raspberrypi: add ENABLE_CMA options to kernel command line
Add ENABLE_CMA setting that enables required kernel configuration to allow the dynamic CMA to function. Change-Id: I0b0ab0fd7fd64454ea3cc9a89344a98897838e11 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com> (cherry picked from commit fefb358dca0ac89b970c77671b2efda2a8cf99c0)
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
index cc6cbeeb5..e5cdb2aff 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
@@ -66,6 +66,9 @@ do_configure_append() {
CMDLINE_DEBUG = ""
CMDLINE_append = " usbhid.mousepoll=0"
+# Add options to allow CMA to operate
+CMDLINE_append = ' ${@base_conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
+
KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
KERNEL_MODULE_AUTOLOAD += "hid-multitouch"