summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-17 01:08:54 +0900
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-17 01:08:54 +0900
commit1a70e5e8f48f17f604ab243dfb3ff01f7aa435f6 (patch)
tree8ecc15ad595d94385fc3b4c578d6c33c13a83c67
parenta7de28858cc5e542da106f92352ffc792a4104cf (diff)
Disable SoC sound driver in porter board
The Porter board currently has a problem that pulseaudio can not be used due to the sound driver. I enabled USB Audio as a workaround, but we had to manually change the default sound device. As a further workaround, disable the SoC sound driver on the Porter board. Change-Id: Ie53b75ea0bc252b82910e518da62d2748147fc90 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend2
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/disable_soc_sound.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
index 57e8d17a2..3bceae5d5 100755
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -1,8 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
# Enable support for TP-Link TL-W722N USB Wifi adapter and RTL2832U DVB USB and USB Audio
+# Disable SoC sound
# adapter.
SRC_URI += " file://disable_delay_printk.patch \
+ file://disable_soc_sound.patch \
file://ath9k_htc.cfg \
file://rtl_sdr.cfg \
file://usbaudio.cfg \
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/disable_soc_sound.patch b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/disable_soc_sound.patch
new file mode 100644
index 000000000..5fa52fa2f
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/disable_soc_sound.patch
@@ -0,0 +1,15 @@
+diff --git a/arch/arm/configs/shmobile_defconfig b/arch/arm/configs/shmobile_defconfig
+old mode 100644
+new mode 100755
+index 432817d..7291d13
+--- a/arch/arm/configs/shmobile_defconfig
++++ b/arch/arm/configs/shmobile_defconfig
+@@ -173,7 +173,7 @@ CONFIG_FB_SH_MOBILE_LCDC=y
+ CONFIG_FB_SH_MOBILE_HDMI=y
+ CONFIG_FRAMEBUFFER_CONSOLE=y
+ CONFIG_LOGO=y
+-CONFIG_SND_SOC_RCAR=y
++#CONFIG_SND_SOC_RCAR is not set
+ CONFIG_USB=y
+ CONFIG_USB_EHCI_HCD=y
+ CONFIG_USB_EHCI_ROOT_HUB_TT=y