summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-11 13:42:19 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-13 20:04:21 +0000
commit2380bc09b584ae176f2275c6ac72d94ebfbf7c3b (patch)
treeb042e8eafa078df997d644ce7911bf64c5b3560e
parent3bd99fb9c93da89564d31cf6579d49213915d2f7 (diff)
dra7xx-evm: add support for multimedia acceleration
TI Jacinto 6 has hardware multimedia acceleration capability. This patch introduces the firmware and IPC components that are needed to control the hardware accelerators. Change-Id: I795c820f9bb87dd77ad227ce7c80f879dd935e54 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch13
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend7
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.08.02.bb35
-rw-r--r--templates/machine/dra7xx-evm/50_local.conf.inc14
4 files changed, 69 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
new file mode 100644
index 000000000..649eef5b1
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
@@ -0,0 +1,13 @@
+diff --git a/linux/src/transport/Makefile.am b/linux/src/transport/Makefile.am
+index 32f0046..b4d3078 100644
+--- a/linux/src/transport/Makefile.am
++++ b/linux/src/transport/Makefile.am
+@@ -32,7 +32,7 @@
+ ##
+
+ # additional include paths necessary to compile the library
+-AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall
++AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall -pthread
+
+ if KERNEL_INSTALL_DIR
+ AM_CFLAGS += -I$(KERNEL_INSTALL_DIR)/include/generated/uapi
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend
new file mode 100644
index 000000000..ca5cdef42
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend
@@ -0,0 +1,7 @@
+#inherit append-code-change
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/patches/:"
+
+SRC_URI_append = " \
+ file://add-dependency-of-pthreads.patch \
+"
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.08.02.bb b/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.08.02.bb
new file mode 100644
index 000000000..8b077b04c
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.08.02.bb
@@ -0,0 +1,35 @@
+python __anonymous() {
+ features = bb.data.getVar("MACHINE_FEATURES", d, 1)
+ if not features:
+ return
+ if "mmip" not in features:
+ raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES')
+}
+
+DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode"
+LICENSE = "TI-TSPA"
+
+LIC_FILES_CHKSUM = "file://MMIP-${PV}-Manifest.doc;md5=81f4b23808c36c9223523f43e35d291c"
+
+COMPATIBLE_MACHINE = "dra7xx"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RDEPENDS_${PN} = " libdce"
+
+SRC_URI = "http://downloads.ti.com/infotainment/esd/jacinto6/glsdk/ipumm/3_00_08_02/exports/ipumm-dra7xx-evm-${PV}.tar.gz;protocol=http"
+
+SRC_URI[md5sum] = "53f47909c2e2575b188bba9ddc325437"
+SRC_URI[sha256sum] = "4ac7598bbbb5dd0cd6504906afe0e09d76ba612a3c326e45425e67535e5f2d09"
+
+S = "${WORKDIR}/ipumm-dra7xx-evm-${PV}"
+
+TARGET = "dra7-ipu2-fw.xem4"
+
+do_install() {
+ mkdir -p ${D}${base_libdir}/firmware
+ cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
+}
+
+FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
+
+PR = "r2"
diff --git a/templates/machine/dra7xx-evm/50_local.conf.inc b/templates/machine/dra7xx-evm/50_local.conf.inc
index 8f6312d5c..ca693c30c 100644
--- a/templates/machine/dra7xx-evm/50_local.conf.inc
+++ b/templates/machine/dra7xx-evm/50_local.conf.inc
@@ -1,5 +1,8 @@
MACHINE = "dra7xx-evm"
+#-------------------------------------------------
+## Graphics section ##
+#-------------------------------------------------
PACKAGES_GFX_${MACHINE} = "omapdrm-pvr"
# Enable Gfx Pkgs
@@ -18,10 +21,21 @@ PREFERRED_PROVIDER_libgbm = "libgbm"
#Preferred versions
PREFERRED_VERSION_libgbm = "10.0.0"
+#-------------------------------------------------
+## Multimedia section ##
+#-------------------------------------------------
+
+PACKAGES_MULTIMEDIA = " \
+ ipumm-fw \
+ pulseaudio-misc \
+"
+PREFERRED_VERSION_ipumm-fw = "3.00.08.02"
+
# Distribution-specific runtime components
IMAGE_INSTALL_append = " \
${PACKAGES_GFX} \
+ ${PACKAGES_MULTIMEDIA} \
"
## ATTENTION, this is needed right now to build meta-ti with AGL: ##