summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-11-02 15:24:51 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-11-02 15:24:51 +0100
commit23ac5169f1ae444d0ebaa064b4206c6de81631c6 (patch)
treedd8c4e99d876b86288f3cbc835bca7c583321fa7
parent9be59d935dce49e99a047b0e2f90b4d13568e7c6 (diff)
Autoload uEnv.txt when agl-sota is enabled
Bug-AGL: SPEC-307 Change-Id: Ide9d4ba013c65cd8162d005006ffe59b0dacddcd Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot/0001-Autoload-uEnv.txt-on-boot.patch27
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot_2013.01.01.bbappend3
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot/0001-Autoload-uEnv.txt-on-boot.patch b/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot/0001-Autoload-uEnv.txt-on-boot.patch
new file mode 100644
index 000000000..a485d7a60
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot/0001-Autoload-uEnv.txt-on-boot.patch
@@ -0,0 +1,27 @@
+From bd56666d27f765113749c2e55eda97b67a659b2b Mon Sep 17 00:00:00 2001
+From: Anton Gerasimov <anton@advancedtelematic.com>
+Date: Wed, 2 Nov 2016 15:17:16 +0100
+Subject: [PATCH] Autoload uEnv.txt on boot
+
+---
+ include/configs/porter.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/include/configs/porter.h b/include/configs/porter.h
+index 45e6556..19dab74 100644
+--- a/include/configs/porter.h
++++ b/include/configs/porter.h
+@@ -151,6 +151,10 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "bootm_low=0x40e00000\0" \
+ "bootm_size=0x100000\0" \
++ "bootcmd=if fatload mmc 1:1 0x50000000 uEnv.txt; then env import -t 0x50000000 ${filesize}; run bootcmd; fi;\0"
++
++/* Shell scripting features */
++#define CONFIG_SYS_HUSH_PARSER
+
+ /* SH Ether */
+ #define CONFIG_NET_MULTI
+--
+2.7.4
+
diff --git a/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot_2013.01.01.bbappend b/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot_2013.01.01.bbappend
new file mode 100644
index 000000000..ab77427fd
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-bsp/u-boot/u-boot_2013.01.01.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append_porter_sota = "file://0001-Autoload-uEnv.txt-on-boot.patch"