summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net>2016-12-14 09:16:22 +0100
committerDominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net>2016-12-14 09:16:22 +0100
commit33a8ffdc64e3296c60f9983835586d4695228c23 (patch)
tree9d07890ccc9980241c41f0a86fee721fb95df8e3
parent30eff0b2111f8e46a15377d7c14a1948e68a0dd5 (diff)
new default weston.ini for Intel
Change-Id: Id899777abafd84bc2c7eb9d3ba0a22906a45c7cb Signed-off-by: Dominig ar Foll (Intel Open Source) <dominig.arfoll@fridu.net>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini21
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend18
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini
new file mode 100644
index 000000000..3cb7095ef
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini
@@ -0,0 +1,21 @@
+[core]
+# shell=desktop-shell.so
+backend=drm-backend.so
+shell=ivi-shell.so
+
+[ivi-shell]
+ivi-module=ivi-controller.so,wl-shell-emulator.so
+ivi-input-module=ivi-input-controller.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
+
+[output]
+name=HDMI-A-1
+transform=90
+
+#[output]
+#name=HDMI1
+#transform=90
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..ba4ed899a
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-intel.ini \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-intel.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+# hack to enable CES Home screen on Intel
+# ln -s ${D}/usr/lib/libEGL.so.1 ${D}/usr/lib/libEGL.so
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "