summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-11 13:52:46 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-13 20:08:48 +0000
commit37238f4c697c566b426256ae32940c873b0d5c44 (patch)
tree636b5cd5b880ef6b77a6eef49d96f16172c486b7
parent472427989fff11e09615067de8e63cf98919df2a (diff)
dra7xx-evm: add platform specific GStreamer plugins
This patch add the GStreamer plugins for hardware acclerated multimedia and video post processing functionality. Change-Id: I4ebed2e183f46f1d7cf1fb47ccec37dc64a026b6 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ducati_git.bb15
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ti.inc23
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe/ti-video.conf1
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe_git.bb18
-rw-r--r--templates/machine/dra7xx-evm/50_local.conf.inc4
5 files changed, 60 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ducati_git.bb b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ducati_git.bb
new file mode 100644
index 000000000..a5d0e80d8
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ducati_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "GStreamer elements to use the multimedia accelerators available on some TI parts"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+
+require gstreamer1.0-plugins-ti.inc
+
+PR = "${INC_PR}.20"
+SRCREV = "7ce9b730de98ceb9d3b63a5977b2e470fab04efb"
+
+BRANCH ?= "master"
+
+SRC_URI = "git://git.ti.com/glsdk/gst-plugin-ducati.git;protocol=git;branch=${BRANCH} \
+ "
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ti.inc b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ti.inc
new file mode 100644
index 000000000..529306bf8
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-ti.inc
@@ -0,0 +1,23 @@
+# Include file for common build settings for TI GStreamer plugins
+DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad libdrm libdce"
+
+inherit autotools-brokensep pkgconfig gettext
+
+INC_PR = "r2"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure() {
+ cd ${S}
+ chmod +x autogen.sh
+ ./autogen.sh --host=arm-linux --with-libtool-sysroot=${STAGING_DIR_TARGET} --prefix=/usr
+}
+
+EXTRA_OECONF += "--enable-maintainer-mode"
+EXTRA_OEMAKE += "'ERROR_CFLAGS=-Wno-deprecated-declarations'"
+
+FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe/ti-video.conf b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe/ti-video.conf
new file mode 100644
index 000000000..339a0c196
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe/ti-video.conf
@@ -0,0 +1 @@
+install ti-vip /sbin/modprobe ti-vpe; /sbin/modprobe --ignore-install ti-vip
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe_git.bb b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe_git.bb
new file mode 100644
index 000000000..c43d27215
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gst-plugins-ti/gstreamer1.0-plugins-vpe_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "GStreamer elements to use the Video Processing Engine (VPE) found on some TI devices"
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+
+require gstreamer1.0-plugins-ti.inc
+
+PR = "${INC_PR}.11"
+SRCREV = "f1d4d67fa7a76f97a49114b1543ee72ecb0192f0"
+
+SRC_URI = "git://git.ti.com/glsdk/gst-plugin-vpe.git;protocol=git \
+ file://ti-video.conf \
+"
+
+do_install_append() {
+ install -d ${D}/etc/modprobe.d
+ install -m 644 ${WORKDIR}/ti-video.conf ${D}/etc/modprobe.d
+}
diff --git a/templates/machine/dra7xx-evm/50_local.conf.inc b/templates/machine/dra7xx-evm/50_local.conf.inc
index 291f10d75..73819807a 100644
--- a/templates/machine/dra7xx-evm/50_local.conf.inc
+++ b/templates/machine/dra7xx-evm/50_local.conf.inc
@@ -27,13 +27,15 @@ PREFERRED_VERSION_libgbm = "10.0.0"
GSTREAMER_PLUGINS = " \
gstreamer1.0-plugins-bad-meta \
+ gstreamer1.0-plugins-ducati \
+ gstreamer1.0-plugins-vpe \
"
-
PACKAGES_MULTIMEDIA = " \
ipumm-fw \
pulseaudio-misc \
${GSTREAMER_PLUGINS} \
"
+
PREFERRED_VERSION_ipumm-fw = "3.00.08.02"
# Distribution-specific runtime components