summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-10-27 11:16:01 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-27 11:26:04 +0000
commit5fb2cb54bc5105d41bcf2012ef5583c752588935 (patch)
treef477ca2fb558843e1199bb01159ee9ad1482a4bf
parent2bf5e31bb042aad10d97b2e701f7330f9d1a66fd (diff)
Enable smack, ramdisk and nbd in linux-staging-ti kernel
This changeset enables the necessary features for AGL in the linux-ti-staging kernel by using configuration fragments. These are additive to the configuration matrix done by linux-ti-staging itself (per board). Apply likewise for other needed options. Change-Id: Iebd212ca81f1c6a7f65f1f413f2021aa11f8190e Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/files/ramblock_nbd.cfg2
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack-default-lsm.cfg2
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack.cfg8
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging%.bbappend7
4 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/ramblock_nbd.cfg b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/ramblock_nbd.cfg
new file mode 100644
index 000000000..ef498669d
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/ramblock_nbd.cfg
@@ -0,0 +1,2 @@
+CONFIG_BLK_DEV_RAM=y
+CONFIG_BLK_DEV_NBD=y
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack-default-lsm.cfg b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack-default-lsm.cfg
new file mode 100644
index 000000000..b5c48454e
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack-default-lsm.cfg
@@ -0,0 +1,2 @@
+CONFIG_DEFAULT_SECURITY="smack"
+CONFIG_DEFAULT_SECURITY_SMACK=y
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack.cfg b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack.cfg
new file mode 100644
index 000000000..62f465a45
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/smack.cfg
@@ -0,0 +1,8 @@
+CONFIG_IP_NF_SECURITY=m
+CONFIG_IP6_NF_SECURITY=m
+CONFIG_EXT2_FS_SECURITY=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_EXT4_FS_SECURITY=y
+CONFIG_SECURITY=y
+CONFIG_SECURITY_SMACK=y
+CONFIG_TMPFS_XATTR=y
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging%.bbappend
new file mode 100644
index 000000000..a1b8ca4ea
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append = " file://ramblock_nbd.cfg"
+SRC_URI_append = " file://smack.cfg"
+SRC_URI_append = " file://smack-default-lsm.cfg"
+
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ramblock_nbd.cfg ${WORKDIR}/smack.cfg ${WORKDIR}/smack-default-lsm.cfg"