summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2016-12-28 07:48:20 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-30 00:04:52 +0000
commit7b1d64975d3d6708c74e534c48230bb1e81bbdee (patch)
tree79eee5d755eea78b9236746aaffeac95453d3773
parentd81c32990a65a8ea4e6da56f4fae54308826e034 (diff)
rpi-config: add configurable CMA low and high water marks
For dynamically allocating of CMA blocks the low and high water marks settings determine when the GPU requests or releases memory from the CPU. Change-Id: Iad494c101fec0884bb687c5ea51c9657b7c17bd9 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com> (cherry picked from commit 6bcd449f3b6f9705dfe940d2011fce6243bac7de)
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index ff14d3640..9222fd52a 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,6 +1,14 @@
DISABLE_OVERSCAN = "1"
do_deploy_append() {
+ if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_LWM}" ]; then
+ sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_HWM}" ]; then
+ sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt