aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-07-17 10:56:57 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-18 08:53:19 +0000
commit04b54deb01c3f3b106471601b3d847617fd9f404 (patch)
tree2e0df92c4516bfce7b2e0e61f4722c70f8e064c4
parent8b237085593840dd846f2fea02c11cd1bd5ef7d6 (diff)
af-main: add RDEPENDS on bash
Currently, we get a file-rdeps QA warning because afm-install has a /bin/bash shebang line but does not RDEPENDS on bash. We could also use /bin/sh instead, but I'm not sure if we have some bashisms built-in to the script. For now, add RDEPENDS to fix the warning. Change-Id: I368da5e9e5c2d57d7bc2a1b674eb84c1147be5c1 Signed-off-by: Martin Kelly <mkelly@xevo.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10221 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 33d380d05..7863874a2 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -45,7 +45,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
FILES_${PN} += "\
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
"
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
DEPENDS_append_smack = " smack-userspace-native"
# short hacks here