aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-10-08 19:20:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-09 10:38:42 +0000
commit4bfc821810cdee47611c6d3e94d771971f51fa75 (patch)
tree060922351aeed4c37df6ce50a3a896369d87850c
parent1cf6b17fd15fde569374c85d4df722784f4e9c67 (diff)
Fix kernel-devsrc package failing during install
This issue is due to the upstream script hardcodes /bin/awk whereas we ship /usr/bin/awk. The installation check will break in this case. Fix it by changing the path in the script. References: https://lists.yoctoproject.org/pipermail/meta-intel/2017-January/004519.html https://patchwork.openembedded.org/patch/136699/ http://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/commit/?h=yocto-4.9&id=d0e0a36eec57f5dfa02045776c69092c145f5000 Bug-AGL: SPEC-933 Change-Id: I8f47aca352c89eef8996670ff7c3ae26c2cb15fc Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11173 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
index b2e543140..43fa494a2 100644
--- a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -31,3 +31,14 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
# file comes out of meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# fix issue in kernel-devsrc meta pkg wrt /bin/awk vs /usr/bin/awk
+do_configure_append(){
+
+# enforce all scripts to use /usr/bin/awk . This fixes the rpm dependency failure on install of kernel-devsrc
+cd ${S} || true
+( for i in `git grep "\!/bin/awk" | cut -d":" -f1 ` ; do sed -i -e "s#\!/bin/awk#\!/usr/bin/awk#g" $i ; done ) || true
+cd ${B} || true
+( for i in `git grep "\!/bin/awk" | cut -d":" -f1 ` ; do sed -i -e "s#\!/bin/awk#\!/usr/bin/awk#g" $i ; done ) || true
+
+}