aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-05 09:33:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-06 19:57:06 +0000
commit52bba290ff9a3204af9ce30c73b1387b72967e1e (patch)
treea61a9bfe87c66278819c30ed1e7c934ba0108526
parent8ef673ec55daa723270e10a175226fa552699901 (diff)
Framework: Leverage agl-devel and set PV
It is time for the framework to include development specific features intended to be used when developing applications. This commit prepares such use. See: AGL-Bug: SPEC-594 It also changes the version PV to point the correct AGL distribution/branch and git commit. Change-Id: Ib399ebe1067892d837bc31363c2c4cf892da6e5e Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10041 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb4
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc3
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index bc4352dc7..5edab2ac1 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -16,10 +16,14 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "17e428f46f0e093270be7eff79788e1575bcfb14"
+PV = "dab+git${SRCPV}"
+
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index 54d6d3026..8d67c66c1 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -15,6 +15,7 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "f36bbef97187012b84f4620fea7cea440741981f"
+PV = "dab+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -24,3 +25,5 @@ afm_datadir = "/var/local/lib/${afm_name}"
afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/usr/local/lib/systemd"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+