aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Field <dennisf@radiosound.com>2017-07-06 16:48:25 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-19 17:08:50 +0000
commit726da22bfc951815defc1cd9da18281b6380b000 (patch)
tree924162b0c7f48feefda2b4d3f27134ae6ceb7e8a
parentd630d90f25accfe40c328132ce34ff2a0fd7b40d (diff)
meta-agl-bsp/meta-intel: make new 4.8 .bbappend
The config fragments were not getting included for kernel 4.8 (intel-corei7-64, Minnowboard) Bug-AGL: SPEC-732 Change-Id: I0ae3e3d40a4e8439274920445108460e16fc42ef Signed-off-by: Dennis Field <dennisf@radiosound.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10073 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Dominig ar Foll <dominig.arfoll@fridu.net> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend6
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.8%.bbappend9
2 files changed, 12 insertions, 3 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
index f94b638b0..26063479e 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
@@ -1,10 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-# adding most supported USB Bluetooth, Wifiand Ehternet devices
+# adding most supported USB Bluetooth, Wifi, and Ethernet devices
SRC_URI_append = " file://usb-devices.cfg"
-
-# adding support for other graphic cards to work on more PC HW
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
+
+# adding support for other graphic cards to work on more PC HW
SRC_URI_append = " file://extra-graphic-devices.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.8%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.8%.bbappend
new file mode 100644
index 000000000..65484da51
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.8%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# adding most supported USB Bluetooth, Wifi, and Ethernet devices
+SRC_URI_append = " file://usb-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
+
+# adding support for other graphic cards to work on more PC HW
+SRC_URI_append = " file://extra-graphic-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"