aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-13 12:02:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-17 09:13:35 +0000
commit8f792e40a5b64dabfa4b51b036e94d19ed312643 (patch)
tree910b4918f8324b86c7671f016d43cc2c6b127891
parente6aef6755ad266f3d1a0fdf14e5924077d12cf8a (diff)
af-binder: Fix const issue in afb-auth.h
The fields type and loa were declared as const. This worked well for C compilers that are allowing to initialize constant fixed structures. But when compiling with C++, it is no more easy to create initialized structure explicitely. In C++, the solution is to use C++14 constexpr functions. But for using these function, const must be removed. Bug-AGL: SPEC-741 Change-Id: If5aca00e79dc074dcd1f6bac81a57d85b8537cea Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10197 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Matt Ranostay <matt.ranostay@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Changhyeok Bae <changhyeok.bae@gmail.com>
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index c0e2a1278..dbde967da 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -15,7 +15,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "4e72c3a2a4e550f99430d1f37a8ef693d2daa8c3"
+SRCREV = "b2a1f5f40ec0663d57a18f97e04d1ce4901af468"
PV = "dab+git${SRCPV}"
S = "${WORKDIR}/git"