aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-06-26 22:41:05 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-29 11:19:15 +0000
commitc8d604496f6bfa707b1e4a51c0e34ee9c074af7a (patch)
tree4f1cb9f51ebd118dd1642c414eb31572f7499a1e
parented8a31d27d5958fe6c8ce1dd0a0199011fab8577 (diff)
weston-init: set udev rule to display group for gst-record feature.
Bug-AGL: SPEC-559 some /dev module should be grant to access as display user. When weston use gst-record, it accesses some /dev driver as display user. Change-Id: Ifc3ab94282d2857d48cfd5673c3eab944badddf3 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9893 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston-init.bbappend b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
index 359cb76e5..2e87572b3 100644
--- a/meta-agl/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
@@ -41,6 +41,14 @@ EOF
SUBSYSTEM=="input", MODE="0660", GROUP="input", SECLABEL{smack}="^"
EOF
+ # user 'display' must also be able to access /dev/media*, etc.
+ cat >${D}${sysconfdir}/udev/rules.d/zz-remote-display.rules <<'EOF'
+SUBSYSTEM=="media", MODE="0660", GROUP="display", SECLABEL{smack}="*"
+SUBSYSTEM=="video4linux", MODE="0660", GROUP="display", SECLABEL{smack}="*"
+KERNEL=="uvcs", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack}="*"
+KERNEL=="rgnmm", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack}="*"
+EOF
+
install -d ${D}${sysconfdir}/tmpfiles.d
install -Dm755 ${WORKDIR}/weston_tmpfiles.conf ${D}/${libdir}/tmpfiles.d/weston.conf