summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-05-23 11:59:38 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-25 12:53:36 +0000
commit77e55a2113167d3fe0d7c8cecbab5365b2512216 (patch)
tree0f1f6badb9d8cb6570feea8756a1e21b668fab36
parent509048c05a3b615e6a044f414f6bff7db68e5c56 (diff)
agl-image-weston: fix weston regression
After 6ca247d (which changed how weston services work) services using weston in agl-image-weston no longer start, saying "Display not found". With this patch, they work again. Change-Id: I7441ce2ece079db8f46a41b2ad3997951d5e18ba Signed-off-by: Martin Kelly <mkelly@xevo.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9495 Reviewed-by: Matt Ranostay <matt.ranostay@konsulko.com> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl/recipes-graphics/images/agl-image-weston.bb3
-rw-r--r--meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb1
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/images/agl-image-weston.bb b/meta-agl/recipes-graphics/images/agl-image-weston.bb
index bc449795d..427132ed6 100644
--- a/meta-agl/recipes-graphics/images/agl-image-weston.bb
+++ b/meta-agl/recipes-graphics/images/agl-image-weston.bb
@@ -7,3 +7,6 @@ LICENSE = "MIT"
IMAGE_INSTALL_append = "\
packagegroup-agl-image-weston \
"
+
+DISTRO_FEATURES_append = " agl-core-image-profile"
+IMAGE_INSTALL_append = " agl-desktop-config"
diff --git a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
index fb7af0a45..dcf21bcfb 100644
--- a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
+++ b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
@@ -10,6 +10,7 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "weston weston-init weston-ini-conf weston-examples"
+RDEPENDS_${PN} += "agl-login-manager"
RDEPENDS_${PN} += "\
packagegroup-agl-image-minimal \