summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-07-25 16:31:47 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-26 06:57:32 +0000
commit62608d5148191be0705a72611f469accf272770f (patch)
tree914f7266d2023e2f9ac40ffba74193f078c45dbd
parent56019433f78c5351ec3acf2b56ac9eddfaa19899 (diff)
Fix build of agl-demo-image-qa
Fix the image generation by fixing SPEC-782, updating iperf and removing our custom version of ltp in favour of a newer version in oe-core. Bug-AGL: SPEC-782 Change-Id: Idbb08b493645f04df3d04c93d7bef8231350078d Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10365 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
-rw-r--r--meta-agl/files/group2
-rw-r--r--meta-agl/recipes-extended/ltp/.appends.core0
-rw-r--r--meta-agl/recipes-extended/ltp/ltp_%.bbappend3
-rw-r--r--meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch52
-rw-r--r--meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch16
-rwxr-xr-xmeta-ivi-common/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch8
-rw-r--r--meta-ivi-common/recipes-test/iperf/iperf_2.0.9.bb20
7 files changed, 97 insertions, 4 deletions
diff --git a/meta-agl/files/group b/meta-agl/files/group
index bd26c5563..dee2ad912 100644
--- a/meta-agl/files/group
+++ b/meta-agl/files/group
@@ -76,7 +76,7 @@ dovenull::966:
quagga::965:
quaggavty::964:
rwhod::963:
-ftp::963:
+ftp::962:
squid::960:
postfix::959:
vmail::958:
diff --git a/meta-agl/recipes-extended/ltp/.appends.core b/meta-agl/recipes-extended/ltp/.appends.core
deleted file mode 100644
index e69de29bb..000000000
--- a/meta-agl/recipes-extended/ltp/.appends.core
+++ /dev/null
diff --git a/meta-agl/recipes-extended/ltp/ltp_%.bbappend b/meta-agl/recipes-extended/ltp/ltp_%.bbappend
deleted file mode 100644
index 22dda1d3f..000000000
--- a/meta-agl/recipes-extended/ltp/ltp_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-SRCREV = "52f4cf73fc1304e1339136729cfc03960d2d7c85"
-
-SRC_URI = "git://github.com/linux-test-project/ltp.git"
diff --git a/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch
new file mode 100644
index 000000000..e8a029790
--- /dev/null
+++ b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0001-fix-out-of-tree-config.patch
@@ -0,0 +1,52 @@
+iperf: fix out of tree configuration
+
+The configure step uses a package header to check for support of types/declares,
+this package header encapsulates all the required system header for providing
+the needed resources. When configured from an out of tree directory the package
+header is not found due to the hard path.
+We now make the path for package header relative to our 'srcdir' so it is
+found appropriately.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 2b3fd20..d420f9e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -176,8 +176,8 @@ dnl Check for system services
+
+ dnl check for multicast
+ if test "$ac_cv_multicast" != no; then
+- AC_CHECK_TYPES(struct ip_mreq,,,[#include "compat/headers_slim.h"])
+- AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
++ AC_CHECK_TYPES(struct ip_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
++ AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
+ AC_MSG_CHECKING(for multicast support)
+ ac_cv_multicast=no
+ if test "$ac_cv_have_decl_IP_ADD_MEMBERSHIP" = yes; then
+@@ -193,9 +193,9 @@ fi
+
+ dnl check for IPv6
+ if test "$ac_cv_have_ipv6" != no; then
+- AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "compat/headers_slim.h"])
+- AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "compat/headers_slim.h"])
+- AC_CHECK_DECLS(AF_INET6,,,[#include "compat/headers_slim.h"])
++ AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "${srcdir}/compat/headers_slim.h"])
++ AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "${srcdir}/compat/headers_slim.h"])
++ AC_CHECK_DECLS(AF_INET6,,,[#include "${srcdir}/compat/headers_slim.h"])
+ AC_MSG_CHECKING(for IPv6 headers and structures)
+ ac_cv_have_ipv6=no
+ if test "$ac_cv_type_struct_sockaddr_storage" = yes; then
+@@ -211,9 +211,9 @@ fi
+
+ if test "$ac_cv_have_ipv6" = yes; then
+ if test "$ac_cv_multicast" = yes; then
+- AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "compat/headers_slim.h"])
+- AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
+- AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "compat/headers_slim.h"])
++ AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
++ AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
++ AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "${srcdir}/compat/headers_slim.h"])
+ AC_MSG_CHECKING(for IPv6 multicast support)
+ ac_cv_have_ipv6_multicast=no
+ if test "$ac_cv_type_struct_ipv6_mreq" = yes; then
diff --git a/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch
new file mode 100644
index 000000000..348e316ce
--- /dev/null
+++ b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/0002-fix-bool-size-m4.patch
@@ -0,0 +1,16 @@
+--- iperf-2.0.5/m4/dast.m4.orig 2016-06-15 11:42:03.945581785 -0400
++++ iperf-2.0.5/m4/dast.m4 2016-06-15 11:42:11.053581641 -0400
+@@ -11,7 +11,12 @@
+
+ AC_DEFUN(DAST_CHECK_BOOL, [
+
+-AC_CHECK_SIZEOF(bool)
++if test "$ac_cv_header_stdbool_h" = yes; then
++ AC_CHECK_SIZEOF(bool,,[#include <stdbool.h>])
++else
++ AC_CHECK_SIZEOF(bool)
++fi
++
+ if test "$ac_cv_sizeof_bool" = 0 ; then
+ AC_DEFINE(bool, int)
+ fi
diff --git a/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch
new file mode 100755
index 000000000..12e8f4631
--- /dev/null
+++ b/meta-ivi-common/recipes-test/iperf/iperf-2.0.9/iperf-2.0.5_ManPage.patch
@@ -0,0 +1,8 @@
+diff --git iperf-2.0.5/man/Makefile.am iperf-2.0.5/man/Makefile.am
+ index ed97bc6..728873f 100644
+--- iperf-2.0.5/man/Makefile.am
++++ iperf-2.0.5/man/Makefile.am
+@@ -1,2 +1 @@
+-man_MANS = iperf.1
+-dist_man_MANS = $(man_MANS)
++dist_man_MANS = iperf.1
diff --git a/meta-ivi-common/recipes-test/iperf/iperf_2.0.9.bb b/meta-ivi-common/recipes-test/iperf/iperf_2.0.9.bb
new file mode 100644
index 000000000..f297f7f7f
--- /dev/null
+++ b/meta-ivi-common/recipes-test/iperf/iperf_2.0.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+SECTION = "console/network"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
+
+SRC_URI = " https://iperf.fr/download/source/${BP}-source.tar.gz \
+ "
+
+SRC_URI[md5sum] = "1bb3a1d98b1973aee6e8f171933c0f61"
+SRC_URI[sha256sum] = "a5350777b191e910334d3a107b5e5219b72ffa393da4186da1e0a4552aeeded6"
+
+S = "${WORKDIR}/${BP}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"