aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Lemke <steve.lemke@lge.com>2018-06-06 02:58:59 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-27 10:40:12 +0000
commit58402f31c58076036463367a6a9022e3192053b9 (patch)
tree0b2d9b4cdf08047f1401e4b2240113c19c5cfe2d
parent7097cb14d333c1876b76ea9cec0d71c59e75aa48 (diff)
Remove pyro 2.3.4 conflicts for Ubuntu 18.04 build
After updating poky to pyro 2.3.4 (to resolve Ubuntu 18.04 build issues) it is necessary to remove conflicting linux-firmware_git.bbappend and bluez patch which are now included in pyro 2.3.4. Tested with poky @ ebb42af2829edfca1a23c7a51a431c656ffc2090 (pyro 2.3.4) Change-Id: Ide27c9c2acf8fa2711035a9472cee3f5d45f016e Signed-off-by: Steve Lemke <steve.lemke@lge.com>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend8
-rw-r--r--meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch34
-rw-r--r--meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend3
3 files changed, 1 insertions, 44 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
deleted file mode 100644
index a34159cad..000000000
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux-firmware/linux-firmware_git.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
-LICENSE_${PN}-ibt-license = "Firmware-ibt_firmware"
-LICENSE_${PN}-ibt-11-5 = "Firmware-ibt_firmware"
-FILES_${PN}-ibt-license = "/lib/firmware/LICENCE.ibt_firmware"
-FILES_${PN}-ibt = "/lib/firmware/intel"
-
-RDEPENDS_${PN}-ibt += "${PN}-ibt-license"
-
-PACKAGES =+ " ${PN}-ibt-license ${PN}-ibt "
diff --git a/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch b/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch
deleted file mode 100644
index 9fac961bc..000000000
--- a/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-All versions of the SDP server in BlueZ 5.46 and earlier are vulnerable to an
-information disclosure vulnerability which allows remote attackers to obtain
-sensitive information from the bluetoothd process memory. This vulnerability
-lies in the processing of SDP search attribute requests.
-
-CVE: CVE-2017-1000250
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 9e009647b14e810e06626dde7f1bb9ea3c375d09 Mon Sep 17 00:00:00 2001
-From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
-Date: Wed, 13 Sep 2017 10:01:40 +0300
-Subject: sdp: Fix Out-of-bounds heap read in service_search_attr_req function
-
-Check if there is enough data to continue otherwise return an error.
----
- src/sdpd-request.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/sdpd-request.c b/src/sdpd-request.c
-index 1eefdce..318d044 100644
---- a/src/sdpd-request.c
-+++ b/src/sdpd-request.c
-@@ -917,7 +917,7 @@ static int service_search_attr_req(sdp_req_t *req, sdp_buf_t *buf)
- } else {
- /* continuation State exists -> get from cache */
- sdp_buf_t *pCache = sdp_get_cached_rsp(cstate);
-- if (pCache) {
-+ if (pCache && cstate->cStateValue.maxBytesSent < pCache->data_size) {
- uint16_t sent = MIN(max, pCache->data_size - cstate->cStateValue.maxBytesSent);
- pResponse = pCache->data;
- memcpy(buf->data, pResponse + cstate->cStateValue.maxBytesSent, sent);
---
-cgit v1.1
diff --git a/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
index 543681550..ffb9d5b53 100644
--- a/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,6 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://bluetooth.conf \
- file://cve-2017-1000250.patch"
+SRC_URI_append = " file://bluetooth.conf"
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf