aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2018-06-05 10:38:03 +0200
committerStephane Desneux <stephane.desneux@iot.bzh>2018-06-05 15:37:42 +0200
commit95b066090dd5022e922dad6fa1f609b757988f67 (patch)
tree02f64d1e0bf5afd10316501233e9a4e079ac706f
parent8a5d68099ba78fff41391e1e4bfe0881cb0f711c (diff)
kern-tools-native: fix fragments merging script
When concatenating kernel config fragments, if a fragment file doesn't end with a carriage return, then the last config option of the fragment and the first one of the next fragment are on the same line in the result file. This leads to misconfiguration because some options are not taken into account. This commit includes a patch that will add a \n in the result file after each fragment. Bug-AGL: SPEC-1475 Change-Id: I52d13b42909f56f4608860af865a80d0d9b2579e Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-agl-bsp/recipes-kernel/kern-tools-native/files/0001-merge_config.sh-add-CR-after-fragment.patch34
-rw-r--r--meta-agl-bsp/recipes-kernel/kern-tools-native/kern-tools-native_git.bbappend6
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/kern-tools-native/files/0001-merge_config.sh-add-CR-after-fragment.patch b/meta-agl-bsp/recipes-kernel/kern-tools-native/files/0001-merge_config.sh-add-CR-after-fragment.patch
new file mode 100644
index 000000000..350f9d4bf
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/kern-tools-native/files/0001-merge_config.sh-add-CR-after-fragment.patch
@@ -0,0 +1,34 @@
+From 8d12bbfc6179d7e9777e4663e10f1795de158b57 Mon Sep 17 00:00:00 2001
+From: Stephane Desneux <stephane.desneux@iot.bzh>
+Date: Tue, 5 Jun 2018 10:53:24 +0200
+Subject: [PATCH] tools/merge_config.sh: add CR after each fragment
+
+If a fragment file doesn't contain a CR at the end, two config options
+may be merged on the same line in the result file, leading to misconfiguration.
+
+This patch adds a CR after each fragment to ensure that config options
+are well separated in the result file.
+
+Bug-AGL: SPEC-1475
+
+Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
+---
+ tools/merge_config.sh | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tools/merge_config.sh b/tools/merge_config.sh
+index 67d1314..296e759 100755
+--- a/tools/merge_config.sh
++++ b/tools/merge_config.sh
+@@ -129,6 +129,8 @@ for MERGE_FILE in $MERGE_LIST ; do
+ sed -i "/$CFG[ =]/d" $TMP_FILE
+ done
+ cat $MERGE_FILE >> $TMP_FILE
++ # workaround for fragments not ending with carriage return
++ echo >> $TMP_FILE
+ done
+
+ if [ "$RUNMAKE" = "false" ]; then
+--
+2.1.4
+
diff --git a/meta-agl-bsp/recipes-kernel/kern-tools-native/kern-tools-native_git.bbappend b/meta-agl-bsp/recipes-kernel/kern-tools-native/kern-tools-native_git.bbappend
new file mode 100644
index 000000000..814278302
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/kern-tools-native/kern-tools-native_git.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "\
+ file://0001-merge_config.sh-add-CR-after-fragment.patch;patchdir=git \
+ "
+