summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-03 18:12:08 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-09 21:23:48 +0000
commit718422057615878c92a5075cdc9ca6dda188d5e2 (patch)
tree563e6976b259e5890148cef71d1704420ab861c4
parent31939127b646c0bfcd3983b8b0bfd4ab46f24e7f (diff)
meta-intel: Include and deploy a startup.nsh file
On EFI systems we need to include a startup.nsh file that EFI will load and run, in the case of not having the device we're booting from be defined in the boot order. We have the kernel provide this as it is independent of boot loader. Bug-AGL: SPEC-898 Change-Id: Ifdf615e78012e2dbcbd87ee97e4c9d9a19ea01fc Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11101 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/files/startup.nsh1
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend7
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/startup.nsh b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/startup.nsh
new file mode 100644
index 000000000..33746243d
--- /dev/null
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/startup.nsh
@@ -0,0 +1 @@
+fs0:EFI\BOOT\BOOTx64.EFI
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
index d524ebfa4..8b490f709 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
@@ -10,3 +10,10 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
# Enable support for usb video class for usb camera devices
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Ensure we have a startup.nsh file
+SRC_URI_append = " file://startup.nsh"
+
+do_deploy_append() {
+ install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
+}