summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-04 17:18:21 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-05 08:04:25 -0500
commit262b016588cb153520362cf0aed3715e43d86672 (patch)
treecadfb60bb3f99c6890b5cea96d417f5c091fa4f7
parent04365253bddc02279bfd6255f734ebd9e703a9c3 (diff)
weston-ini-conf: update gst-record logic
The logic to handle the "virtual-output" and "gst-record" DISTRO_FEATURES seems to be unfinished, this update replaces the "virtual-output" usage with just "gst-record", as the former does not seem to exist in the AGL codebase. The virtualoutput.cfg file has been updated with the arguments from the virtual output section in the replacement .ini file from the mapviewer-demo recipe in meta-agl-demo, but some further investigation is required into tweaking things to produce a final .ini file that matches that one. These changes are a first step to getting to that end goal. Change-Id: Ib99e0717ed1e66016c6e936a3c398addcb6adfb7 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend9
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg5
2 files changed, 5 insertions, 9 deletions
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend
index de388d862..00cd35b3a 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -2,16 +2,11 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-#
-SRC_URI += "${@bb.utils.contains("DISTRO_FEATURES", "virtual-display", "file://virtualoutput.cfg", "",d)}"
+SRC_URI += "${@bb.utils.contains("DISTRO_FEATURES", "gst-record", "file://virtualoutput.cfg", "",d)}"
do_configure_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'virtual-display', 'true', 'false', d)}; then
- echo virtual=1 >> ${WORKDIR}/core.cfg
- fi
-
if ${@bb.utils.contains('DISTRO_FEATURES', 'gst-record', 'true', 'false', d)}; then
- echo recorder=true >> ${WORKDIR}/virtualoutput.cfg
+ echo virtual=1 >> ${WORKDIR}/core.cfg
fi
}
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg
index 76f536ff8..ef3e7814f 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg
@@ -1,7 +1,8 @@
[output]
name=virtual1
-mode=1920x1080@30
+mode=1920x1080@60
+recorder=true
ip=192.168.20.99
port=5005
-bitrate=3000000
+bitrate=300000
crop=384x368@0x0