summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-06-27 19:17:08 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-28 13:20:59 +0000
commit40bdea4f047cc82a085a3dceff3d893582c0b206 (patch)
tree79aa4f2eaa96cbc514cf3db2b47f149f1a0e0596
parent19bb8c74dd58851d27afbc34a9c656dc5b852a46 (diff)
recipes-core: systemd: move canbus-can.network script
Move canbus network script from meta-agl-profile-telematics to meta-profile-core. Since this is useful for more than just telematics Bug-AGL: SPEC-2580 Change-Id: I93666d87f1fb3eb037743d2858a8757d6939c5e3 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network (renamed from meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network)0
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend4
-rw-r--r--meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend8
3 files changed, 4 insertions, 8 deletions
diff --git a/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network b/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network
index 9768c4bf9..9768c4bf9 100644
--- a/meta-agl-profile-telematics/recipes-core/systemd/files/canbus-can.network
+++ b/meta-agl-profile-core/recipes-core/systemd/systemd/canbus-can.network
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
index 815fed8a3..8c7da4390 100644
--- a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
file://e2fsck.conf \
+ file://canbus-can.network \
${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
"
@@ -14,6 +15,9 @@ do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ # Install canbus network script
+ install -m 0644 ${WORKDIR}/canbus-can.network ${D}${base_libdir}/systemd/network/60-canbus-can.network
+
if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
# Install DHCP configuration for Ethernet adapters
install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
diff --git a/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend b/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index 5e02b2b24..000000000
--- a/meta-agl-profile-telematics/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI_append = "file://canbus-can.network"
-
-do_install_append() {
- mkdir -p ${D}${base_libdir}/systemd/network
- install -m 0644 ${WORKDIR}/canbus-can.network ${D}${base_libdir}/systemd/network/60-canbus-can.network
-}