summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-16 09:26:32 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 19:32:20 +0000
commitd05fb3624e57051a2403827d4b685c7bd85ace35 (patch)
tree71dd2557e1304b4046c236530512b16d44eb6f4a
parent4344daec0ffb0fcb20b5b8c4662838e64a539af2 (diff)
Remove obsolete examples
At this time, many demo examples are available to demonstrate use of AGL framework. Keeping these obsoletes examples introduces confusion. Maintaining these examples is possible but not done from what I see. In conclusion, removing it is much cleaner. Change-Id: I29a68eabf48a72d4a681de9b641da72f647ffbac Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12017 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework-examples.bb2
-rw-r--r--meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb29
-rw-r--r--meta-app-framework/recipes-example/afb-client/files/afb-client7
-rw-r--r--meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb40
-rw-r--r--meta-app-framework/recipes-example/afm-client/files/afm-client7
-rw-r--r--meta-app-framework/recipes-example/afm-client/files/afm-client.service11
6 files changed, 0 insertions, 96 deletions
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework-examples.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework-examples.bb
index e95b7548b..7ba909162 100644
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework-examples.bb
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework-examples.bb
@@ -11,6 +11,4 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
- afm-client \
- afb-client \
"
diff --git a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
deleted file mode 100644
index f272b264f..000000000
--- a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "HTML5 demo template for AFB"
-DESCRIPTION = "afb-client is a sample AngularJS/HTML5 application using \
-Application Framework Binder with token binding."
-HOMEPAGE = "http://www.iot.bzh"
-
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
-
-#DEPENDS = "nodejs-native"
-RDEPENDS_${PN} = "af-binder af-binder-binding-authlogin"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
-SRC_URI_files = "file://afb-client \
- "
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-SRCREV = "9e9b459fa27d7a359a060024c9639b99b45813d5"
-S = "${WORKDIR}/git/afb-client"
-
-do_install () {
- mkdir -p ${D}/${datadir}/agl/afb-client
- cp -ra ${S}/dist.prod/* ${D}/${datadir}/agl/afb-client/
-
- mkdir -p ${D}/${bindir}
- install -m 0755 ${WORKDIR}/afb-client ${D}/${bindir}/afb-client
-}
-
-FILES_${PN} += "${datadir}"
diff --git a/meta-app-framework/recipes-example/afb-client/files/afb-client b/meta-app-framework/recipes-example/afb-client/files/afb-client
deleted file mode 100644
index 99e6aa968..000000000
--- a/meta-app-framework/recipes-example/afb-client/files/afb-client
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if [ -z "${XDG_RUNTIME_DIR+1}" ]; then
- export XDG_RUNTIME_DIR=/run/user/$UID
-fi
-LD_PRELOAD=/usr/lib/libEGL.so /usr/bin/qt5/qmlscene http://localhost:1234/opa /usr/share/agl/afb-viewer.qml
-
diff --git a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
deleted file mode 100644
index 159f69f01..000000000
--- a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Sample client for AFM to install/start/stop/remove applications"
-DESCRIPTION = "afm-client is a sample AngularJS/HTML5 application using \
-Application Framework Manager to install, start, stop, or remove \
-applications provided as .wgt widget packages."
-HOMEPAGE = "http://www.iot.bzh"
-
-inherit systemd
-
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
-
-#DEPENDS = "nodejs-native"
-RDEPENDS_${PN} = "af-main af-binder af-main-binding af-binder-binding-demopost af-binder-binding-authlogin"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
-SRC_URI_files = "file://afm-client \
- file://afm-client.service \
- "
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-SRCREV = "9e9b459fa27d7a359a060024c9639b99b45813d5"
-S = "${WORKDIR}/git/afm-client"
-
-do_install () {
- mkdir -p ${D}/${datadir}/agl/afm-client
- cp -ra ${S}/dist.prod/* ${D}/${datadir}/agl/afm-client/
-
- mkdir -p ${D}/${bindir}
- install -m 0755 ${WORKDIR}/afm-client ${D}/${bindir}/afm-client
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_user_unitdir}
- install -d ${D}${sysconfdir}/systemd/user/default.target.wants
- install -m 0644 ${WORKDIR}/afm-client.service ${D}/${systemd_user_unitdir}/afm-client.service
- ln -sf ${systemd_user_unitdir}/afm-client.service ${D}${sysconfdir}/systemd/user/default.target.wants
- fi
-}
-
-FILES_${PN} += "${datadir} ${systemd_user_unitdir}"
diff --git a/meta-app-framework/recipes-example/afm-client/files/afm-client b/meta-app-framework/recipes-example/afm-client/files/afm-client
deleted file mode 100644
index ba868e93d..000000000
--- a/meta-app-framework/recipes-example/afm-client/files/afm-client
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if [ -z "${XDG_RUNTIME_DIR+1}" ]; then
- export XDG_RUNTIME_DIR=/run/user/$UID
-fi
-LD_PRELOAD=/usr/lib/libEGL.so /usr/bin/web-runtime http://localhost:1236/opa
-
diff --git a/meta-app-framework/recipes-example/afm-client/files/afm-client.service b/meta-app-framework/recipes-example/afm-client/files/afm-client.service
deleted file mode 100644
index 735717439..000000000
--- a/meta-app-framework/recipes-example/afm-client/files/afm-client.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Simplest application manager
-
-[Service]
-ExecStart=/usr/bin/afb-daemon --mode=remote --port=1234 --token='' --sessiondir=/home/root/.afb-daemon --rootdir=/usr/share/agl/afm-client --alias=/icons:/var/lib/afm/icons
-Restart=on-failure
-RestartSec=5
-
-[Install]
-WantedBy=default.target
-