summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2017-11-30 18:01:56 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-01 21:42:10 +0000
commitf64bdf74f4ce5e6b0041669289bc0f8548d3cd42 (patch)
tree500add29a94998c6c4fdd79a02b967650b36b524
parent095c333c3cd2cd95bd49acb6eb50d5a6db514eaf (diff)
meta-agl-bsp: move usbaudio.cfg to linux-agl.inc
USB audio should be enabled for all AGL BSPs. Move the usbaudio.cfg from the Renesas BSP bbappend (it's actually not even used there as the fragment is not being appended) to linux-agl.inc and append it. Bug-AGL: SPEC-1148 Change-Id: I219d0d0355a4d57f883086631e07f3d191be2975 Signed-off-by: Matt Porter <mporter@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12281 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend1
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-agl.inc3
-rwxr-xr-xmeta-agl-bsp/recipes-kernel/linux/linux/usbaudio.cfg (renamed from meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/usbaudio.cfg)0
3 files changed, 3 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
index 8776a847c..ee4d25f56 100755
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -6,7 +6,6 @@ SRC_URI += " file://disable_delay_printk.patch \
file://cfg_mac_80211.cfg \
file://ath9k_htc.cfg \
file://rtl_sdr.cfg \
- file://usbaudio.cfg \
file://ra2x00.cfg \
file://0001-media-r820t-do-not-double-free-fe-tuner_priv-in-r820.patch \
file://0002-media-r820t-remove-redundant-initializations-in-r820.patch \
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc b/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
index b9d199c45..db37ab2f5 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
@@ -29,6 +29,7 @@ SRC_URI_append = "\
file://hid.cfg \
file://drm.cfg \
file://btusb.cfg \
+ file://usbaudio.cfg \
"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
# Enable support for usb video class for usb camera devices
@@ -42,6 +43,8 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/hid.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/drm.cfg"
# Enable Bluetooth USB devices
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/btusb.cfg"
+# Enable USB audio devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usbaudio.cfg"
# Enable required features for the agl-netboot feature
SRC_URI_append_netboot = " file://nbd.cfg \
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/usbaudio.cfg b/meta-agl-bsp/recipes-kernel/linux/linux/usbaudio.cfg
index 5961f43d3..5961f43d3 100755
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/usbaudio.cfg
+++ b/meta-agl-bsp/recipes-kernel/linux/linux/usbaudio.cfg