summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-08-22 15:25:01 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-23 19:49:44 +0000
commitc7167b47cce11eb33b43407be65b2debf16605ee (patch)
treed823e467568784dd826291a5cb1ac53d72d7c8f7
parentdcb3dfede296347bc5194e55f0cc34a7f9a672a3 (diff)
Add lua-dev and lua-staticdev to minimal crosssdk image
Change-Id: I28d58ec2096531e6db008f8417c47fde23768994 Bug-AGL: SPEC-1678 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rwxr-xr-xmeta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
index 164e1e9f5..44c43c54a 100755
--- a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
+++ b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
@@ -11,6 +11,19 @@ LICENSE = "MIT"
IMAGE_FEATURES_append = " dev-pkgs"
IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+# required dependencies for app and test builds
+# also in the minimal image (SPEC-1678)
+TOOLCHAIN_HOST_TASK += " \
+ nativesdk-lua \
+ "
+
+# required dependencies for app and test builds
+# also in the minimal image (SPEC-1678)
+TOOLCHAIN_TARGET_TASK += " \
+ lua-dev \
+ lua-staticdev \
+ "
+
inherit populate_sdk
# Task do_populate_sdk and do_rootfs can't be exec simultaneously.