summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhouloud Touil <ktouil@baylibre.com>2018-07-02 13:46:42 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-04 09:59:20 +0000
commitf8829aaefc1c7ddf8766c9a10ac7bb0c074a08df (patch)
treeb51d10cd06cb56354d93f52268a8da25708dd530
parente1964500cee5c72429b0deae6bb33d4f69b44716 (diff)
Enabling the DCAN2 interface
Modify the DTS file, to add the proper pinmux for the DCAN2 and enable it Change-Id: I21d233eab71d062484f322e8dd0f16df34f6fe76 Signed-off-by: Khouloud Touil <ktouil@baylibre.com>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch39
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend10
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch
new file mode 100644
index 000000000..22f467599
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/files/dcan2_pinmux_enable.patch
@@ -0,0 +1,39 @@
+diff --git a/arch/arm/boot/dts/dra7-evm.dts b/arch/arm/boot/dts/dra7-evm.dts
+index 02dc1ae..ec0acfe 100644
+--- a/arch/arm/boot/dts/dra7-evm.dts
++++ b/arch/arm/boot/dts/dra7-evm.dts
+@@ -166,6 +166,20 @@
+ DRA7XX_CORE_IOPAD(0x3818, MUX_MODE15 | PULL_UP) /* wakeup0.off */
+ >;
+ };
++ dcan2_pins_default: dcan2_pins_default {
++ pinctrl-single,pins = <
++ DRA7XX_CORE_IOPAD(0x3688, PIN_OUTPUT_PULLUP | MUX_MODE2) /* gpio6_14.dcan2_tx */
++ DRA7XX_CORE_IOPAD(0x368C, PIN_INPUT_PULLUP | MUX_MODE2) /* gpio6_15.dcan2_rx */
++ >;
++ };
++
++ dcan2_pins_sleep: dcan2_pins_sleep {
++ pinctrl-single,pins = <
++ DRA7XX_CORE_IOPAD(0x3688, MUX_MODE15 | PULL_UP) /* gpio6_14.dcan2_tx.off */
++ DRA7XX_CORE_IOPAD(0x368C, MUX_MODE15 | PULL_UP) /* gpio6_15.dcan2_rx.off */
++ >;
++ };
++
+ };
+
+ &i2c1 {
+@@ -652,6 +666,13 @@
+ pinctrl-2 = <&dcan1_pins_default>;
+ };
+
++&dcan2 {
++ status = "ok";
++ pinctrl-names = "default", "sleep";
++ pinctrl-0 = <&dcan2_pins_default>;
++ pinctrl-1 = <&dcan2_pins_sleep>;
++};
++
+ &dsp1 {
+ status = "okay";
+ memory-region = <&dsp1_cma_pool>;
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
index 02161415f..a280223ed 100644
--- a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -1,2 +1,12 @@
require recipes-kernel/linux/linux-agl.inc
require recipes-kernel/linux/linux-agl-4.9.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+#-------------------------------------------------------------------------
+# patches for enabling dcan2 and fix dcan1 & dcan2 adresses
+
+SRC_URI += " \
+ file://dcan2_pinmux_enable.patch \
+ "
+