summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2018-09-25 20:51:28 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-09-28 16:50:23 +0000
commit9fe7ad39f8b78c4e912569b48781a535be38be14 (patch)
tree41d8361c2b604ddd5d74c3286068bd9e0c354c70
parent2188d0890f7c61db7cc7f5fd9b0c2795dd67695d (diff)
weston-ini-conf.bbappend: Set 720p for Raspberry Pi
Reduce the screen resolution for Raspberry Pi from Full HD to HD Ready (1280x720) to reduce the memory consumption and improve the behaviour of the whole system. This change is applied only for HDMI display on Raspberry Pi due to the limited hardware resources. Bug-AGL: SPEC-1745 Change-Id: Id2fb571b0822f8166086f5ad6a7fcf8ea25c933a Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270-720p.cfg7
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
index 33dfd6a23..d652d6bee 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,3 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://dsi.cfg"
+
+# Reduce the screen resolution to HD Ready (720p)
+SRC_URI_remove = "file://hdmi-a-1-270.cfg"
+SRC_URI_append = "file://hdmi-a-1-270-720p.cfg"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270-720p.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270-720p.cfg
new file mode 100644
index 000000000..e1c9db1a8
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270-720p.cfg
@@ -0,0 +1,7 @@
+# A display is connected to HDMI-A-1 and needs to be rotated 270 degrees
+# to have a proper orientation of the homescreen. For example the various sizes
+# of the GeChic display or the Dell display.
+[output]
+name=HDMI-A-1
+transform=270
+mode=1280x720