summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-10-09 11:35:53 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-10-19 09:25:48 +0000
commitb2611f285b92a6611f539a878fe5f81939236d1d (patch)
tree49b3cf801e1e34dd964341a2e37d3f5c5e4fa11d
parent430b602c068015ea4ce02a4df882c11505d7c100 (diff)
Bump afb-test revision
Fix afm-test script installation e82fde7 Shellcheck: protect variable against whitespace 9ec26c0 Improve exit output message 5cbc238 Test the LockWait feature a525f24 Unify test launch between target and native a1369a9 Update documentation 9754027 get rid of afb-definitions 5e36513 Avoid to kill anything when no config file found c3aae9c Separation between CB and classic test functions c541040 Rename test service api to be more discriminant. 79bb6f3 Assert that an event hasn't been received c227156 Script for both native and target launch Change-Id: Ic2b3d68cdb2b57613a0a24e42e43f307b2cae399 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
index bbc156efd..03e2dcfc0 100644
--- a/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
+++ b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
@@ -6,20 +6,22 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SECTION = "apps"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "bba4befcc57ff4eb106a01b416119da01accfcd1"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH} \
+ file://run-ptest \
+ "
+SRCREV = "e82fde7d6f1b8714dfcf4eb0f77ae0f98d7f4636"
DEPENDS += "lua"
RDEPENDS_${PN} += "lua bash"
RDEPENDS_${PN}-ptest += "af-binder"
-PV = "5.99-FF.RC6.0+git${SRCPV}"
+PV = "${AGLVERSION}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig ptest
do_install_append() {
- install -d ${D}${bindir}
- install -m 775 ${B}/afm-test ${D}${bindir}/afm-test
+ install -d ${D}${bindir}
+ install -m 775 ${S}/afm-test.target.sh ${D}${bindir}/afm-test
}