summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrique Ferreiro <hferreiro@igalia.com>2018-11-23 01:24:41 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-23 12:51:43 +0000
commit803f03daebb58b3a26462df35f001637f2ddf9a0 (patch)
tree83e1afb48f9ddadd0f65191e74547db278ac9554
parenta3ca29a42903dca7b73d1cb98d097d5634e26694 (diff)
Provide fallback time servers to connman
connman NTP client needs some fallback time servers in case it cannot get one from the DHCP server. Bug-AGL: SPEC-1925 Change-Id: I904f49f7d9428a2cc4e90ccea387bf4892f4d38e Signed-off-by: Henrique Ferreiro <hferreiro@igalia.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend11
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/files/main.conf2
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index e41cbe954..57406fa0a 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -1,3 +1,12 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://0001-disable-when-booting-over-nfs.patch"
+SRC_URI += "file://0001-disable-when-booting-over-nfs.patch \
+ file://main.conf \
+"
+
+FILES_${PN} += "${sysconfdir}/connman/main.conf"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/connman
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+}
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
new file mode 100644
index 000000000..0bfbe09dc
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
@@ -0,0 +1,2 @@
+[General]
+FallbackTimeservers=pool.ntp.org