aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-16 22:47:01 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-20 11:18:07 +0000
commit2fc0726d1f7e2a0f224dcc304546386b71b5e6c0 (patch)
tree1d980b02c86614ffafcdd1d3aa3b148c715fb7a0
parent88c2da9145d067ec5497099addb05803065f5bf4 (diff)
polkit-rule-agl-app: add useradd class and USERADD_PARAMoctopus_15.0.3octopus/15.0.315.0.3
The only diff left to e.g. polkit and systemd is the USERADD_PARAM. Add it into the recipe by using inc file from polkit. Bug-AGL: SPEC-4824 Change-Id: I18a8ddd6b772403de89aeac73e34c30d847d0d6d Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29027 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
index 920bb86b3..d71a2df46 100644
--- a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
+++ b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
@@ -4,13 +4,14 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://50-agl-app.rules"
-DEPENDS += "polkit"
-
-inherit features_check
-REQUIRED_DISTRO_FEATURES = "polkit"
+# need to include polkit group rules
+include recipes-extended/polkit/polkit-group-rule.inc
+USERADD_PACKAGES = "${PN}"
do_install() {
install -m 700 -d ${D}${sysconfdir}/polkit-1/rules.d
- chown polkitd:root ${D}/${sysconfdir}/polkit-1/rules.d
+ chown polkitd:root ${D}${sysconfdir}/polkit-1/rules.d
install -m 0644 ${WORKDIR}/50-agl-app.rules ${D}${sysconfdir}/polkit-1/rules.d
}
+
+FILES:${PN} += "${sysconfdir}/polkit-1/rules.d/*.rules"