summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-12-20 15:59:47 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:12:29 +0000
commit73351742e32772a19f62086cea5a5e7a38fe02f7 (patch)
treeaae6de92cf51192cb37d2317d3eed436c6abd9ca
parent4824f74346855b0fd61d22d3e1b9e7f67388e6c3 (diff)
Add afb-helpers & app-controller library recipes
Migration for afb-helpers and app-controller from submodule to library. This adds the library in the AGL SDK. Bug-AGL: SPEC-1689 Change-Id: I95b1e66b2a363ce1bbea7cc8989992a7b592d264 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb18
-rw-r--r--meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb19
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
new file mode 100644
index 000000000..26bfd926e
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/libafb-helpers/libafb-helpers_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AFB helpers library"
+DESCRIPTION = "AFB helpers library to ease JSON object manipulation and binding interaction"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libafb-helpers;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "9cdebd57cf048c1c9ba89943f6ec2f9012bad6fc"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder qtwebsockets"
+RDEPENDS_${PN}_append = " af-binder"
+
+inherit cmake_qt5
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb b/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
new file mode 100644
index 000000000..5130ef2a2
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/libappcontroller/libappcontroller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Controller library for an Application Framework"
+DESCRIPTION = "Controller library to be used to easily create a binding for AGL App Framework"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libappcontroller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "09bdc519439aae889d80f1018507cd5395f5ad03"
+
+PV = "${AGLVERSION}"
+S = "${WORKDIR}/git"
+
+DEPENDS_append = " af-binder libafb-helpers lua"
+RDEPENDS_${PN}_append = " af-binder lua"
+
+inherit cmake
+
+ALLOW_EMPTY_${PN} = "1"
+