summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-10-23 14:22:26 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-10-29 14:24:23 +0000
commit067dace0f08268770f1001947fda9af10ef02bd6 (patch)
treefdad8f6e45c8491c0e52c54262102392a59603f4
parente28b57f91a916aa09bcbc25ba109338731a70a23 (diff)
Add CMake Apps module recipe
Adds the cmake-apps-module in the SDK and the normal Yocto builds. Bug-AGL: SPEC-1682 Change-Id: Ib8b83dd9664a1566318eb0a140e043c5d82510ce Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb22
-rw-r--r--meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend4
-rw-r--r--meta-app-framework/classes/aglwgt.bbclass3
3 files changed, 28 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb b/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
new file mode 100644
index 000000000..0a2a6452a
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/cmake-apps-module/cmake-apps-module_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "CMake module to ease development of apps"
+DESCRIPTION = "This is a migration of former app-templates git submodule which let you \
+ease the development of apps and widget building."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/cmake-apps-module"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+SECTION = "apps"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "2beffef345c6bf96078aae711d78dec973a93ef6"
+
+PV = "${AGL_BRANCH}+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit nativesdk cmake
+
+FILES_${PN}_append = " ${datadir}/*/Modules/CMakeAfbTemplates.cmake \
+ ${datadir}/*/Modules/CMakeAfbTemplates/* \
+ "
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index 504a019b4..a6c709342 100644
--- a/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/meta-agl-profile-core/recipes-devtools/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -1 +1,3 @@
-RDEPENDS_${PN} += "nativesdk-low-level-can-generator"
+RDEPENDS_${PN} += "nativesdk-low-level-can-generator \
+ nativesdk-cmake-apps-module \
+"
diff --git a/meta-app-framework/classes/aglwgt.bbclass b/meta-app-framework/classes/aglwgt.bbclass
index 8a2c351e0..46a27c14f 100644
--- a/meta-app-framework/classes/aglwgt.bbclass
+++ b/meta-app-framework/classes/aglwgt.bbclass
@@ -15,6 +15,9 @@ DEPENDS_append = " af-main-native"
# for bindings af-binder is required.
DEPENDS_append = " af-binder"
+# for bindings that use the cmake-apps-module
+DEPENDS_append = " cmake-apps-module-native"
+
# for hal bindings genskel is required.
DEPENDS_append = " af-binder-devtools-native"