summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-11-20 18:21:43 +0200
committerScott Murray <scott.murray@konsulko.com>2018-11-22 14:58:56 +0000
commit8a0cd7c69c5df85924f3f065d0ef0f71d490e599 (patch)
treeda60c5127aae7c64e1d77c8e6e1d5d969ecb0ff4
parent9cffd21d1ec735c871943a301d46e3816e18a320 (diff)
recipes-connectivity: bluez5: add dbus-org.bluez.obex.service symlink
To allow OBEX service to be requested by a user on demand there needs to be a symlink /etc/systemd/user/dbus-org.bluez.obex.service to the obex.service Change-Id: If4b8a94790403cf7f8f2a53ce3365c5f8c9f3b2c Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index c5afa875f..9c49ad0e9 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -10,4 +10,9 @@ SRC_URI_append = "\
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ mkdir -p ${D}/etc/systemd/user
+ ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
+ fi
}